Performance issues when when smooth scrolling with hardware acceleration on

Description of the issue:
Desktop browser fails to load pages and may become irresponsive when smooth scrolling with hardware acceleration on.
How can this issue be reproduced?

  1. Go to Settings → System
  2. Toggle “Use hardware acceleration when available” if not already on
  3. Open any web page with plenty of vertical space to scroll vertically in (example: Twitter)
  4. Scroll down by either pressing the scroll wheel or using the scroll arrows to the far right side of the screen

Actual Result:
Browser won’t load new content until scrolling stops, and will struggle to keep up with mouse movements updating them at a delay, if not becoming completely unresponsive to any mouse inputs unless minimized and brought back up.

Expected result:
Responsive scrolling the same as scrolling a page by scrolling the mouse wheel.

Brave Version:
v 1.58.137

Additional Information:
Scrolling works as normal with hardware acceleration turned off. If it’s any help, my OS and hardware specs are as follows:
Windows 10 (v10.0.19045)
Ryzen 7 5700X
Nvidia RTX 3050

@MattFright (copy/paste of a reply I just had for someone else)

it suggests graphics card/driver issues. This has especially been a thing for some people with NVIDIA. Solutions have ranged to what you see below:

The list goes on. But definitely have been a wide range of issues and solutions so far. As stated, usually nothing to do with Brave but instead to do with drivers or settings. It might be easier to go with the first step of reinstalling/resetting your drivers first to see if it helps.

1 Like

Tried renaming the executable first since it was the easiest solution and it worked, for some reason even after then renaming it back to brave.exe (at least after running it as chrome.exe once).

Don’t know why but i guess that’s the issue solved :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.