Pasting images into Discord is broken on Brave

Description of the issue:
When using the Discord chat app, Images in the clipboard can’t be based into the chat field. This used to work in brave and still works on chromium, but became broken some unknown time after a change to Discord’s layout. (EDIT: the change in layout may be unrelated, see post below)

How can this issue be reproduced?

  1. Open the discord chat app in one tab. Go to any conversation channel, on a server or in a DM.
  2. In another tab, got to a website that has an image and rightclick->copy the image to the clipboard (not a link to the image!)
  3. Rightclick in the chatbox in Discord and select paste, or use the standard paste shortcut. Nothing happens.

This does work however if pasting an image copied from another program, for example paint or another browser. It also works if the Discord web app is opened in another browser like chromium.

Expected result:
Being able to paste images into the discord chat box. In stead of nothing happening, discord should show a thumbnail of the image in the chatbox post-paste.

Brave Version( check About Brave):

Version 1.35.100 Chromium: 98.0.4758.87 (Official Build) (64-bit)

I need to restart brave t go to the latest version (I haven’t for a few days) but this issue has existed for several months and I’ve waited for discord to fix it on their end.

Additional Information:
This is known to affect linux and believed to affect windows as well.

1 Like

After a cursory look, this issue seems similar to

I’ve noticed I have a similar problem in that I can’t paste a copied image into paint, so maybe this is an issue when Brave writes to the clipboard rather than when reading from it. I can paste into brave from other programs just fine so far.

Issue persists on Version 1.37.111 Chromium: 100.0.4896.79 (Official Build) (64-bit)

Issue persists on latest version. Brave seems to copy images to the clipboard (or fails to) in a format that cannot be read back when pasting into discord.

problem only affects brave browser

I’m getting the same issue.
Version 1.37.116 Chromium: 100.0.4896.127 (Official Build) (64-bit)

Problem persists.
Version 1.39.122 Chromium: 102.0.5005.115 (Official Build) (64-bit)

I’ve noticed that if I restart the browser, the first image I copy and paste into discord works, but none after that. the steps to reproduce this are:

restart Brave
go to an image sharing site
right click an image, copy image
paste into discord, image works
copy the same image, or a different image, from the same image sharing site
it doesn’t work the second time, with any image.

The fact that it behaves in this particular way, and the problem is not on any other browser, tells me that it is definitely a problem with Brave, and possibly some small mistake. The topic specifically mentions Discord, and it’s what I’m experiencing the issue with too, but this will obviously apply to other websites and it needs to be fixed.

Looks fine here? Other than trying to copy a larger image and getting the discord warning;

test images: & & @beebee

None of those images work for me. I can open them just fine, right click and say “copy image” but then if I try to paste them into discord nothing happens. Discord doesn’t even react.

A few questions. Does the context menu shows in the copy and paste? Does private window mode work better?
Does a clean Brave profile help?

The context menu shows the copy and paste options. When I click paste, the context menu simply closes. No image appears in input field.

I reset the settings of my browser. I assume this is what you mean by a clean Brave profile. When I google “clean brave profile” I get steps on how to delete my account here. I’m not going to do that. Anyway, after clearing the settings, the bug persisted.

Restarting the browser didn’t help. As before, the first image worked, but then it never worked again.

The problem persists in a private browsing window.

This problem existed from the moment I began using Brave, which was with the first version I mentioned in this thread, and it was before I made this account. So if you mean a clean profile on this site, well I started with a completely new profile and the problem was there from the beginning. I re-installed brave, and the problem persisted.

Thank you for responding to us.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.