Opening email client via Brave

Hello,

I was using Brave for a few years now and never experienced any problems until a few days ago.
When I was clicking on an emailadress online, Brave always opened my emailclient (Airmail/Mac) automatically. Suddenly this changed and it opened my Gmailaccount. I’ve been trying to find a solution under ‘preferences’ and online but could not figure out how to change things back to Airmail.

I uninstalled Brave and reinstalled it. Now it does not connect to any of my email clients. A new (white) window pops up

Very frustrating. I hope somebody can help me with this one.

Thanks and regards,
Dirk

Hi @Dutchie58, Welcome to Community!
Can you try going to brave://settings/handlers and letting me know if it’s enabled?

Hello,

Thank you for your reply. Yes, handlers is enabled. There was my gmail account but I deleted it. I want Brave to open my email client, Airmail. Can you please tell me how to set that as my preference?
Thank you and regards from The Netherlands.

Hi @Dutchie58,
Go into brave://settings/handlers and disable it.
Then to make Airmail your default mail client go to Apple Mail app preferences and set default mail reader as Airmail.

1 Like