Change default mailto: link behvior

Description of the issue:

Clicking on mailto: links sends Brave to Gmail instead of system default email client

Steps to Reproduce (add as many as necessary): 1. 2. 3.

1> Click on any mailto: link
2> Should open Airmail 4 (defined default email client)
3> Brave opens new tab in Gmail instead of email client

Reproduces how often:

Every time

Operating System and Brave Version(See the About Brave page in the main menu):

macOS 10.15.4
Brave [Version 1.8.86 Chromium: 81.0.4044.129 (Official Build) (64-bit)]
Airmail 4.0.7 (App Store version)

How do I force Brave to open the mail client instead of a Gmail web page?

Brave V1.8.86
macOS 10.15.4 (19E287)
Spark Mail 2.6.0.708 and Apple Mail 13.4 (3608.80.23.2.2)

I do have the very same annoying problem.
Every time I press a “mailto” link, Brave does change to the Gmail Login Page!
With Safari, Firefox I don’t see this kind of problems.
Please let us know how to fix that.

Thank you

Thank you Developers, it’s working now again.
But it would have been kind of respectful to reply to our bug message.
Have a good save time.

This is not working for me. I want to set Brave to use Spark as my email handler. Spark is my MacOS default.

Figured it out. Open Mail app. Set default mail app to Spark. Close Mail app. Now Brave honors that setting and uses Spark to open mailto: links.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.