Brave made web based Gmail default browser on all apps?


I had to open up the actual mail app and do the following:

Mail > Preferences > General > Default Browser: Mail

Hopefully this helps someone else. I do not know how or why this defaulted as the main email but that was really annoying. When trying out new software, the last thing I want is for it for force itself on me. It’s like the McAfee bloatware on a windows device. I feel like I’m a hot chick at a frat party with how persistent it is on trying to get to me.

Original question below:

I installed Brave today on Mac OS 11.2

No idea how or why, but it does not matter what App I am using, if I click the share button and select “email this page” it opens up Gmail in Brave.

It happens even when Brave is completely closed out.

I did not ask for this. I do not want this. I do not know how to fix it. Please help me get my mail app back to my default when pressing the share button. I’ve searched through OS11 preferences and cannot find this option.

Thank you so much for any help.

Topic resolved. Mods can close. Fix in edit up top.

1 Like