Brave and mailto: handlers

Description of the issue:

I know this has been discussed before on these forums, but the suggested solutions don’t work. All of a sudden, Brave has started to handle email links on developer support pages by opening another tab and sending me to my gmail account instead of sending the link to my email client. I have checked the MacOS setting in Mail, and it is correctly set to my email client.

I’ve even tried resetting cookies and cached files, but that made no difference (except to send me to a Google login page instead of directly to gmail). I am, however, reluctant to reset Brave for fear of having to spend a long time reinstalling extensions, resetting preferences, etc.

Brave Version( check About Brave):

Version 1.11.104 Chromium: 84.0.4147.105 (Official Build) (64-bit)

@thersites,
Setting the Mail app to be the default should have resolved the issue – not sure why else it would be doing that. One thing to check is whether or not you have any email protocol handlers in Brave, and see if removing them changes the behavior.

Simply go to brave://settings/handlers and see if gmail (or any online mail client) is there and if so, remove it and let me know the results.

That was the problem! Thanks so much for the quick reply.

I was looking for a handlers setting in Preferences, but ccouldn’t find one. Can this one be made more accessible?

1 Like

The fastest way to get to that setting and related ones is to navigate Menu --> Settings --> Privacy/Security --> Site and Shield Settings.

You can also enter brave://settings/content in the address bar which will take you to the above page directly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.