Open new tab freezes Brave window for 2 secs

Same issue here. This is nightmarish.

3 Likes

Me too. Same problem!

4 Likes

The same also keep happening for me. it takes up to 10 seconds to open a new tab and it freezees the whole adress bar and I can’t do anything. I hope the devs can fix this soon!

Edit: What i meant by having a problem opening a new tab is when i click on this " + " icon in the address bar NOT when i see a new page and I Right-click " open this page in a new tab ".

3 Likes

Adding my voice to the choir. Only happens with new tabs / windows loading the default Brave screen. I have Sponsored, Rewards and Binance turned off. Turning them on has no effect, nor does turning everything off.

This is on my 3 month old PC, but not on my 10+ year old laptop both running the latest Win 10. Not helpful, I know, but interesting nonetheless.

4 Likes

As mentioned by this poster here, there are extensions that bypass Brave’s new tab. Here’s one, there are several others that probably function the same.
—>Salvation<—

This worked. New tabs come up with blank page instantly. Thanks to OP for the idea.

4 Likes

While I don’t like having to use an extension as a bandaid I appreciate the info. Ill be using it until this is fixed and I will be watching these threads.

3 Likes

this is good and it works good too

@BillGates tells us he does not like using an extension as a band-aid

nither do i or probably too a many in the choirs

I appreciate the info. Ill be using it until this is fixed and I will be watching these threads. :wink:

thanks

1 Like

Same issue occurring over this past week; 20 seconds to open a new tab - is this Binance related? The only cure I found was to switch away from Brave which was a real shame as it is a great browser.
Thanks to algore for the workaround I’ll try it and hope that the issue is fixed temporarily and hope for a permanent fix asap. I’ll continue using a different browser otherwise. I also detest the forced updates, I’m trying Host file mods currently.

1 Like

I’m experiencing the same issue here (5 seconds-freeze on Brave when I open a new tab) and I expecting a fix for this issue. In the meantime I thank @algore and the OP workaround that works perfectly.

2 Likes

+1 on that problem. Used to work fine and was really responsive (except for when I tried sync), but recently something caused it to lag unbearably long. Blank tab extension worked, as promised in here. Kind of a bummer, I don’t need the frontpage but I would like it regardless.

1 Like

Same problem here.
Created bug report before found this topic.
Sorry for duplicate.

1 Like

I have the same issue… but it is taking 18-20 seconds before it can be used.

1 Like

Nothin happens to me when using

1 Like

Throwing my hat into this thread…

Using Linux. It happened when upgrading from Pop_OS (aka Ubuntu w/skins/extensions) 19.10 to 20.04 that also upgraded Brave. Thought it was the new Pop_OS mess that did it so I switched to Regolith (i3-gaps+gnome) which didn’t fix it.

But after reading this thread across many OS (macOS, Windows), it’s obvious it was a Brave upgrade.


FYI, I tried disabling all of the “Customization” on the new tab page - none had any effect.

1 Like

It all started several days ago when Brave was updated to 1.8.86.

Now it has been updated to Version 1.8.90 Chromium: 81.0.4044.129 (Official Build) (64-bit), but the start new tab freezing issue still remains as is.

The current workaround is to use an extension called “Blank New Tab Dark Mode” that overrides the New Tab page with a dark blank page. It works perfectly, but I would like to have things back to normal again as they used to be.

3 Likes

Dear Brave developers, it’s ridiculous to release 2 updates and leave unfixed this crucial issue. Brave browser is unuseless now. Switching back to Google Chrome.

1 Like

Me as well. Brave 1.8.96 on Mac OS 10.15.4. Roughly 10 seconds every time; I think this has gotten longer over the past couple weeks, as though an ever-lengthening log file was being parsed, or some such,

I also see an issue Facebook where entry into a new post pauses for a few seconds and then moves the insertion point to the start of what had already been entered. Seems to happen in other browsers as well, so maybe unrelated,

1 Like

The new tab hangs on the Brave browser for several seconds. The current behavior with Brave is browser freeze till the new tab comes online.
the bug is in loading the new tab content from somewhere. An easy fix is to override new tab content with an extension. I tried the following and the tabs open immediately.

Tab Override

1 Like

Hangs when you launch Brave or a New Tab have been tied to a minor bookmark integration feature available on the New Tab Page. We’ve decided to change this in future builds, which should result in substantially faster launch-to-load times. Thank you all for the feedback!

3 Likes