Can't block autoplay on soundcloud

Thanks for the reply @Mattches.

The more I test this bug, the weirder it gets.

The cosmetic part of the issue seems mostly confined to the page at brave://settings/content/siteDetails? On I see one of the following:

If the default is selected (which still shows as Allow (default) on the settings page), it doesn’t appear in the dropdown on soundcloud. On the settings page, if I have selected Block, but the option shows Allow, selecting Allow has no effect, I have to switch to default and then to Allow to make it take effect. Additionally, If I select Default or Block, the change is reflected immediately on the soundcloud dropdown, but if I select Allow, the change is not reflected until I refresh soundcloud. (Actually, after more testing, now it is reflected immediately, I don’t know what caused the change.) I do see the prompt to refresh the page for changes to take effect.

If the option is shown in the dropdown on soundcloud, which only happens if it is not the default, then I can modify it in the dropdown and it appears to be acting normally, however if I set it to default and then refresh the page, the option is gone from the dropdown.

Another quirk: If I have it set to default (which should be Block, but shows as Allow), and then either load or refresh brave://settings/content/autoplay, the dropdown on brave://settings/content/siteDetails? immediately switches from Allow (default) to Block (default).

Under no circumstances is the setting respected on soundcloud, although I have noticed a variable: If I only have one soundcloud tab open, it always autoplays. If I have more than one soundcloud tab open, it never autoplays. Also, pressing play on one soundcloud tab pauses any other soundcloud tabs. It appears that soundcloud is somehow managing its own autoplay setting.

This issue does not happen with every site, however I have just confirmed the same behavior on Some sites seem to be able to override my browser settings.

1 Like