No default printer settings

Mac OS 10.14.6
Brave always defaults to size A4 paper size for printing even though this is on a US system with Letter as the default printer size. Brave does not get the system’s default printer paper size.

Hello @BurtGreen, thank you for reaching us out. Does the same behavior happen in a different Browser? Have you tried opening the printer menu and then going to > Preferences > Advanced and adjusting these options before printing the file?

Hope this helps. Regards.


This printer problem is exclusive to Brave. Other browsers work correctly. I have never had size A4 paper set for my printer. This paper size does not exist in the US. My default printer setting is Letter. See screen shot attached.

Ideally, Brave would have an exposed printer settings dialog, that allows one to access this. It does not.


I have the opposite problem, the paper defaults to Letter size, rather than A4. As far as I know, this size isn’t available here in the UK. All other browsers default to A4.

Hello again @BurtGreen @Robo1, apologies for the delay! Is this still an issue for you?

Yes, Brave is still overriding the default paper set on the printer. I’ve moved back to Chrome for work as it’s just easier for printing documents.

Hi, Yes it’s still broken in both ways.

  1. The print output for a browser page is ¼ sized in the upper left corner instead of printing the full-sized page. The print preview in the print dialog is correct. If I print the same page out to a PDF the sizing is correct.

  2. There is no printer setting in the Brave settings. Brave always defaults to A4 page size in spite of being on a US system where the default is Letter size paper. I have to set the paper size in the print dialog each time I print. Brave does not recognize the system default nor does it remember the last setting.
    This is on Mac OS 10.14.6 outputting to a Canon MX922. Brave Version 1.48.171 Chromium: 110.0.5481.177 (Official Build) (x86_64) There are no issues like this printing from Chrome or Safari on the same system. I have attached a sample print.

I have exactly the same problem :frowning:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.