No bookmarks in Bookmarks menu after latest upgrade

Description of the issue:

The Bookmarks menu no longer contains my bookmarks after the latest Brave update. I can still see them in the Bookmarks Manager or when enabling View > Always Show Bookmarks Bar, but the Bookmarks menu only contains the three built-in actions (Bookmarks Manager, Bookmark This Tab …, Bookmark All Tabs …)

How can this issue be reproduced?

I’m not sure this is reproducible; but in my experience,

  1. Have bookmarks in Bookmarks menu
  2. Upgrade browser and restart
  3. No bookmarks in Bookmarks menu

Expected result:

I would expect my bookmarks to still be visible in the menu, after a divider and below the built-in menu entries.

Brave Version( check About Brave):

Version 1.43.86 Chromium: 105.0.5195.68 (Official Build) (x86_64)

Additional Information:

MacOS Monterey 12.5.1

Nvm - upgrading to 1.43.89 Chromium: 105.0.5195.102 (Official Build) (x86_64) brought back the bookmarks.

It happened again after a day or two of use. Still a problem, in other words (though the fact that upgrading solved it temporarily suggests that a restart might help, too).

Can you add a screenshot of when the issue occurs?

Are you using any extensions? Have you tried disabling them?

Here’s a screenshot. I am using TamperMonkey and a number of scripts within that, but I have been using it for a couple of years without any issues. The only thing which changed recently is I started to use my bookmarks more regularly.

Inspired by your question, I tried opening a new private window, and sure enough, the bookmarks are visible when I am visiting that. Maybe there is something wrong with one of the TamperMonkey scripts after all.

1 Like

I’m seeing the same “disappearing bookmarks” issue after the last Brave update.

The bookmarks menu sometimes shows only the first 3 items (same as on @tripleee -s screenshot), and some time later the menu also shows actual bookmarks.
This seems to be completely random; a browser restart might or might not make the bookmarks reappear.

I’m not using TamperMonkey or any other fancy extensions.

Are you also on a mac?

What about the rest of the behavior outlined above – does the behavior go away in a Private window?

Yes, this is on a Mac.

MacOS: 12.5.1
Brave: Version 1.43.89 Chromium: 105.0.5195.102 (Official Build) (arm64)

Right now, opening a Private Window makes bookmarks reappear in the menu, but I’m not sure if that’s always the case.

The issue can be reproduced by opening and closing a private window.

Version 1.43.93 Chromium: 105.0.5195.127 (Official Build) (x86_64)
macOS Monterey Version 12.6

I’ve run into this exact same issue. In fact, I came here looking to see if others had as well.
I can’t seem to find a pattern that causes it but quitting Brave and reopening resolves it for some amount of time before it happens again.

Version 1.43.93 Chromium: 105.0.5195.127 (Official Build) (arm64)
macOS Monterey version 12.5.1

I have the exact same issue. Bookmarks disappear but I can see them in Private mode. Also, restarting Brave they come back for a while, then they disappear again.

Version 1.43.93 Chromium: 105.0.5195.127 (Official Build) (arm64)
macOS Monterey version 12.5.1

Not sure. There appears to be a pattern though, perhaps limited to macOS users?

@Mattches any ideas?

I see what I think others are saying about a private window. That seems to be a work around. I’ve been keeping a private window open in the background and that keeps the bookmarks menu functioning as normal.

Sorry for the late reply here everyone. Wondering if this is a Chromium based issue — although I myself am not able to reproduce this. Bookmarks appear for me in the menu in both Private and standard browsing windows.

I know at least @vapper has stated that they’re not using any “fancy” extensions, but I am curious if anyone encountering this has any extensions enabled at all at this time? I’m also wondering if this same behavior occurs when using a new browser profile?

I tried with a new browser profile (no extensions or any settings changed from default) and had the same issue.

I believe it’s happening only on my M1 Mac. I also have an Intel iMac and have not noticed the issue there.

Sorry for not doing more detailed testing, but:

I don’t have any bookmarks with the "bookmarks" permission set (in the extension’s manifest.json), so if it’s an extension’s fault then it still looks like a Brave/Chromium bug (because as I understand, extensions shouldn’t get access to bookmarks at all without that permission set.)

We’ve open an issue to track this as some of our team members can reproduce the issue as well. Still likely a chromium issue but worth flagging anyway. You can track progress on the issue here: