New Brave crypto wallet not working

Hi, recently my Brave crypto wallet was updated automatically (without prompt!) with new interface and all. However I am unable to use it to interact with DEXes like 1inch, Trader Joe, etc. Sending coins and swapping coins and smart contracts are all affected too. The confirm/approve button is not clickable when the DEXes tried to interact with my wallet. or sometimes even after clicking the confirm button (when possible), then nothing happens, I dont see the transactions on chain at all. And the “activity” tab is also missing. Pls help asap! and if possible can I have back the original “Metamask” like interface, its much easier and familiar to use. Pls help asap! Thanks!!!

Go to settings click on wallet>use old deprecated wallet.

Though for me the new wallet worked fine.

1 Like

I’d recommend staying with the new Brave Wallet but as the above user mentioned you can get back to the old wallet at any time, so your funds are safe. There was a hotfix that was just released (1.32.113) so if you update to that by going to Brave | About Brave, then hopefully the problems you had will be gone.

1 Like

@brian

Unrelated to this thread.
Has an opinion/recommendation that:-
Can brave browser have in-built out of the box support for I2P protocol. Right now we need to manually change settings to connect to I2P network. Considering Brave’s work for web 3.0 like IPFS, ENS, Tor it will be pretty good if I2P is also added to the list.

If funding is a problem, we can have community run donations via BAT for those who want I2P in browser.
So any plans for it??

Thanks for the suggestion, I think it’d be best to post a suggestion here including how you think that should work http://github.com/brave/brave-browser/issues

1 Like