Crypto Wallet no longer working properly

This last update wiped out my crypto wallet networks and you can no longer properly add networks, in one example fantom, it will not accept the Chain ID. The chain ID is 250 but when you go to enter into brave wallet it says “Invalid format, the chain id is a 0x-prefixed hexadecimal string”, there is no 0x id, it is litterly 250 for Opera network. After this update you guys messed this up big time, why did it not import the networks I already had setup? And why will it not accept the network ID like it was before? Also, why is there ridiculous stuff like “currency decimals” which was never something that needed to be entered previously? Please fix this asap.

1 Like

I got this to add by using chainlist, but now transactions will not work over the Fantom Opera mainnet, and it thinks that 98 FTM is $.001. What did you guys do? This was working great before why did you change it.

Something def not right, transactions do not work on rarity.

Its very frustrating and this was not resolved since 4 days ago. I cant make any transactions or even to say transfer out of brave wallet. This is an irresponsible upgrade by default. Really losing faith in brave.

We’re improving that UX for the chain ID, sorry for the trouble.
250 in base 10 is the same as hex 0xFA
So you need to enter 0xFA for now until we improve that user input.
You can also use chainlist.org to make it easier to add.

You’re also right that we missed the mark on not importing people’s networks as well automatically. We’ll improve this in another update. Sorry for the trouble.

If worse comes to worse you can always get back to your old wallet in chrome://settings/wallet under default wallet setting, by setting it to Crypto Wallets. However the new wallet will have a lot of new innovation and features so if you just add the networks into the new wallet that would be best.

exact date for this please.

Every release and hotfix will be adding fixes and features. So there’s no exact date, it’s an ongoing thing.

1 Like

I was able to fix this for now by switching to the “Crypto Wallets (Deprecated)” under wallets settings. Be aware though it will require your old password, good thing I am paranoid and saved both. Thanks Brian, please let me know when the new one is working correctly.

We fixed the input on our Nightly channel but it hasn’t gotten to release yet. It will be available by the 1.33.x release.

But I’d recommend changing back to Brave Wallet in the meantime. If you need to add networks simply use an easier to use interface like chainlist.org in the meantime.