Metamask not updating in Brave Browser

I’ve just updated to the latest version of Brave ( 1.27.111) but my Metamask extension is showing an old version (v. (Metamask on Chrome updated fine). I would greatly appreciate some guidance on how to fix. I suspect it might have something to do with the newer Wallets function on Brave, but I’m just guessing. Anyone? Thanks in advance!

I am having a similar problem. I have connected accounts where i stake coins and suddenly these accounts don’t link and I can’t see my stakes. You mention that you have metamask on chrome too. So you use both browsers and that hasn’t caused any problem up until now? You still had access to your transaction history?

The Metamask I use on Brave is a completely separate wallet from the one on Chrome. I’ve had no issues. The Chrome MM updated fine and I used it w/out problem today. The Brave MM is still an old version. It’s supposed to update automatically, but it hasn’t done so and I can’t figure out how to manually update.

This is very concerning. So, I hope someone from Brave support responds quickly. Thanks.

Thank you for reaching out. I’m looking into this presently, can you tell me what OS you’re using currently?

Thank you, Mattches! MacOS Big Sur 11.5.1. FYI, on Brave I’m using MM w/ Grid+.

UPDATE: The issues I had w/transactions failing apparently had nothing to do with the last Metamask version. I still don’t really know what happened, but everything started working again when I accidentally clicked on the little button that turns the little MM interface into the full page interface in Brave. So strange.

That said, I would like guidance on the best Brave settings to use with the Metamask Wallet. On the advice of some people in various forums, I turned off “Load Crypto Wallets on startup,” and for “Ethereum provider for using dapps” I chose NONE. I guess I’ll stick with those settings as long as everything keeps working.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.