Transactions Not Working After Wallet Update

I updated the Brave Wallet and the new version recognizes all my tokens, but my swap transactions will not work. I get a DEX message saying I am not authorized to transact. I have the 24-word seed phrase wallet. I followed the upgrade instructions given and set a new password when prompted to do so. Is there a setting I can adjust to allow transactions? Thanks.

Update/Solved: I closed Brave and re-logged-in using ‘deprecated wallet’ mode in settings with the old password. The old wallet appears, and works fine. Thank you.

Could you try again with the new Wallet after the hotfix we just released (1.32.113)? In brave://settings/wallet switch back to “Brave Wallet (Prefer Extensions)” and then it should work. If not please let us know which DEX you’re having trouble with. Thanks!