Netflix does not work on Brave

Description of the issue:
After updating Brave to the newest version of the beta; Netflix will no longer work and instead produces the following error message: m7121-1331. I followed all of the troubleshooting steps which were outlined on the Netflix website; ( but to no avail. I also installed the non-Beta version of Brave but the error message prevailed.

I tried using Microsoft Edge and there were no issues with streaming; ergo I am inclined to think this is an issue with Brave.

I have also made sure that I have the latest version of Widevine.

How can this issue be reproduced?

  1. Not sure.

Brave Version( check About Brave):
Brave 1.12.86 Chromium: 84.0.4147.85 (Official Build) beta (64-bit)

Additional Information:

On my end, Netflix is working on all Brave builds, on both macOS and Windows 10 systems. Can you check brave://compontents and see if Widevine has been properly installed?
You should see the following listed on the components page

If it is, can you try creating a new profile (Menu --> Create new profile) and login to Netflix and see if you’re able to stream content?

1 Like

Hi, Thanks for the reply. @Mattches

When I go into the chrome://components page; I seem to have the same exact Widevine version as you. As seen:

I have also created a new profile as you have suggested, but the issue still persists with the same exact error code.

Perhaps I could try to remove said component and attempt to reinstall it by visiting Netflix again. I just remembered that: when uninstalling Brave during my initial troubleshooting; when I visited the the Netflix site post the fresh install I was not greeted with the popup to allow the Widevine module; as if it had stayed post the uninstall.

Does other Netflix titles work?

Nope. This same exact error shows up; regardless of what title.

Alright; so I have found the root cause for my issue- Turns out it has nothing to do with Brave directly. I use quite a few custom extensions that are not available on the Google Chrome Web-store. And each time I would launch Brave a pop up would appear that would outline that I should disable ‘Developer Mode Extensions’. So I attempted to find a workaround this pop-up and found a chrome.dll patcher on git-hub. ( It seems that tampering with the chrome.dll file would cause issues with streaming content from services that use the Widevine drm. This is further supported by the fact when a backup of the chrome.dll is loaded (pre-patching); the issue is gone and Netflix works flawlessly.

Im going to further investigate this on the patchers github page.

Thank you for the assistance @Mattches , @fanboynz !

Also; would there potentially be a way to implement some sort of Brave-feature to remove this popup? In a way that does not break content streaming… hh

1 Like

chrome://flags/#enable-force-dark not working on android with the latest version kindly fix

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.