Need help about hardware acceleration

So when I have hardware acceleration off everything works mostly fine except that web events form mihoyo are super laggy if i turn on hardware acceleration my YouTube videos will flicker black and red
This didnt happen when i installed brave on my hdd, after reinstalling it on a brand new ssd this happens.
does anyone have a fix for this?

Hi

@Hypoxia This might help you: I have brave on ssd with the following settings

my nvidia GPU is set to AUTO-SELECT,
nvidia driver up to date,
Hardware acceleration is disabled in Brave,
OS Windows 11.
Works perfect.

I have the exact same settings but on windows 10

@Hypoxia Have you tried opening you tube and mihoyo in a private mode window? If it works try disabling extensions to see if one of them is the problem.

@Hypoxia Open task manager, and send me a screenshot of Brave processes.
@Hypoxia Also check the following default settings

@Hypoxia Check the default settings for

Opening up in a private windows yields the same results.
I tried disabling smooth scroll but that didn’t change anything
The other settings were at default (which is enabled)


i also noticed high cpu usage when opening the web events

Hi

@Hypoxia

  1. Try disabling Continue running background apps when Brave is closed @ brave://settings/system

  2. Try ‘experimenting’ here by changing feature settings.

Many users have this issue probably due a bug in Windows 10. Plz leave the post open for others to contribute.

i would suggest as @CerealLover said to select fixed gpu for brave so try with nivida first if it work fine then keep it if not then try the integrated one

hdd or ssd does not affect the hardware acceleration it’s about your gpu

@CerealLover @justsomeone1
As per your advices
Continue running background apps when Brave is closed is already disabled
and selecting a preferred graphics processor is on my gpu by default since i dont have intergrated graphics


At this point, would reinstalling brave help?

@Hypoxia

From the Brave community posts, it is clear to me that many Windows 10 users are having a similar graphics problem; It is probably because of a bug and I dont think reinstalling Brave would solve the problem. Also reinstalling Brave has its consequences as regards BATs.
I suggest you leave the post open such as anyone can contribute and if something new shows up i’ll let you know.

@CerealLover
Alright thank you for your help

does that mean you reinstall the whole os and was it the exact (mean same build) version ?

not sure if that would help but give it a try go to menu and select create a new profile and see if you have same issue or not?

reinstalled a fresh OS on my SSD, making a new profile doesn’t seem to help the problem

i did not ask for reinstall the os i was asking about this

and you still did not answer this