Moving tabs with click and drag is not working anymore

Description of the issue:
When I try to move a tab with drag and drop inside the opened window, the tab opens in a new window, instead of moving inside the tab list of the same window. It also happens in privacy mode and when I disable all extensions.

In a different profile on the same machine the drag and drop moving is still working.

How can this issue be reproduced?

  1. Click a tab
  2. Try to move it inside the window

Expected result:
I would expect the tab move inside the same window

Brave Version( check About Brave):
Version 1.34.80 Chromium: 97.0.4692.71 (Offizieller Build) (64-Bit)

EDIT:
At some systems, but not all, @felipeiise solution seem to solve the problem:

Link to the post to like if it worked for you: LINK

8 Likes

HI there I am also having the same issue form about an hour. Can’t get it to working
Manjaro with kernel version 5.14.21
Brave Version( check About Brave ):
Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-Bit)

Having this from when I turned my computer on from about 3 hours a ago. Restarted to no avail.

I am having the same issue in Brave browser Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-Bit).

I have a Kubuntu 20.04 LTS 64 bit. This is a problem in this new version of Brave browser. Before upgrading to this version it was working 100%

1 Like

Brave team, I found the bug!!!

It is not in Brave browser, but in Chromium source code.

Because I also tested in Chromium browser Version 97.0.4692.71 (Official Version) snap 64 bits and it has THE SAME ISSUE.

So I suggest Brave team to downgrade to a previous version of Chromium source code and launch an update with it.

3 Likes

Not sure if anyone else has noticed that you actually can’t drag or drop anything in Brave after the latest update? You use to be able to drag websites into the bookmark bar as well, but that doesn’t seem to work any more either? Think I’m going to start using Opera instead.

2 Likes

Same issue myself.

Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-bit)

Same issue for me as well after the latest upgrade
Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-bit)

Installed from the AUR https://aur.archlinux.org/packages/brave-bin/

Can confirm this is also not working in the brave beta
Version 1.35.77 Chromium: 97.0.4692.71 (Official Build) beta (64-bit)

GitHub Issue for those interested: https://github.com/brave/brave-browser/issues/20386

2 Likes

Same here;
Brave version: 1.34.80 Chromium: 97.0.4692.71
Just realized how often I’m using drop and drag on tabs. Hoping there’ll be a Chromium version rollback soon until this is fixed.

Same here @ Manjaro Linux,
Version 1.34.80 Chromium: 97.0.4692.71 (Offizieller Build) (64-Bit)

Fixed with downgrade to 1.33.106

$ sudo apt-get install brave-browser=1.33.106

4 Likes

Not sure I want to downgrade.

Another interesting datapoint is that I run Ubuntu (also 21.10) on my MacBook and there are no issues on that machine…

I was having my issue with kubuntu 21.04 on a laptop.

Fixed with downgrade. There’s no downside to downgrade except seeing the “updates available” in your notification bar.

Well there ya go! A downside! :wink:

1 Like

On brave://settings/appearance

You can disable “Use system title bar and borders”

That fixed the problem for me, apparently the update enabled this option by default

3 Likes

worked like a charm thanks :wink:

Use system title bar and borders was already disabled for me. This doesn’t work for me with it enabled or disabled.

3 Likes

felipeiise’s fix didn’t work for me either as of 12, Jan 2022.

“Use system title bar and borders” was not checked for me. As a test I turned it on, closed Brave, then opened it again, and unchecked it. Did not fix the issue.

This is honestly a huge issue in my workflow? I often have dozens of tabs open doing research for my job, and i like to sort and group them by windows. Not being able to drag tabs or rearrange tabs is a HUGE issue in my workflow.

I even specifically joined the support community so I could look up if there was a solution to this!

I’m on Kubuntu 21.20, Brave Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-bit)

2 Likes

Same issue on EndeavourOS KDE Plasma latest version and Kubuntu. Use system titlebars only changes the look but not the behaviour.

It occurred few days ago after some update of Brave. Can’t tell exactly when, haven’t used those laptops for quite a while.

This is not a solution for me. I am seeing that ALL “drag and drop” functionality in Brave 1.34.80 is non-functional on OpenSUSE KDE Plasma, even after turning off “Use system title bar and borders” and browser restart and reboot.

This means the Bookmarks page is broken, I can’t claim my monthly earned BAT because the “captcha” fails, and any website that uses drag and drop is broken. :frowning:

1 Like

Thank you. For me it solved the problem under Ubuntu 21.10 with Gnome Shell.