Moving tabs with click and drag is not working anymore

UPDATE: the BETA version of Brave has the same problem – any kind of drag and drop does not work. Tried dragging bookmarks and bookmark folders and nothing happens.

Brave 1.35.77 Chromium: 97.0.4692.71 (Official Build) beta (64-bit)
Revision adefa7837d02a07a604c1e6eff0b3a09422ab88d-refs/branch-heads/4692@{#1247}
OS Linux
JavaScript V8 9.7.106.18
1 Like

Same issue. I’m on Deepin. Happened after I did an update and now I can’t use any drag or drop functionalities.

Same problem for me.
It’s really annoying because I enjoy Brave (on Arco Linux KDE)

This is NOT a solution for many of us. I’ve never had “Use system title bar and borders” toggled on. Tried it. Didn’t fix it.

This fix did not work for me on Arch KDE Plasma Xorg

Hello, this is an issue for me as well Ubuntu 20.04 kubuntu. Huge impact on workflow.

Same issues with tabs and rewards captcha. Opensuse Tumbleweed. Installed the previous Brave version thru Yast Software Manager and all is fixed and got my BAT rewards into my acct.

I have the same issue in Arch KDE.

It seems like it’s been fixed via this bug report, but just not rolled into Brave yet.

https://bugs.chromium.org/p/chromium/issues/detail?id=1279532

Edit: To be clear, the marked solution on the post did not solve this issue for me. It’s not resolved.

1 Like

Thank you very much. It worked for me.

This bug is a issue in Chromium source code, but until Chromium launches the solution in stable version (until now they launched the solution in beta version) and then, Brave launches a stable update with the chromium stable solution, we will need to wait at least more two weeks, so thank you very much for your quickly solution.

I will wait more 30 days to update Brave (even if they launches an update in the next two weeks), just to be sure that all things are working again.

I really think Brave team should test Chromium new version before launches new version, to avoid new issues like this.

Your answer does not seem right. First off, I run Brave Beta and it doesn’t have the fix. Well that at least on my Ubuntu desktop. Running the same Ubuntu OS on my laptop does not exhibit the problem. So it’s not fixed in beta and it’s not broken on all machines.

And who’s marking this as fixed as it is still demonstrably broken.

Same here on Debian testing, X.Org, KDE Plasma. Brave stable installed from official repository and is up-to-date (1.34.80). The “Use system title bar and borders” fix didn’t work for me, too. After downgrading to 1.33.106 all works fine.

@defaria
Please pay attention. The bug is in Chromium version 97.0.4692.71 Probably this Brave beta you are using has this version of chromium (or another 97 chromium version). I read on the Chromium forum, that the solution was released in the next version (98) of Chromium, but it is still in Beta (I cannot confirm, because I have not test it, only read this information in Chromium forum). I preferred to downgrade and install the version of Brave that contains Chromium 96, with no bugs. We will have to wait maybe more two weeks until brave launch the next stable version with the correction of this bug. I recommend to you do the same (make a downgrade).

2 Likes

Lots of people have had success with downgrading their version of Brave but I have no idea how to do it on Kubuntu, if someone could possibly point me in the right direction I’d appreciate it!

EDIT: with enough googling I finally was able to figure out how to downgrade to version 1.33.106 - I can move tabs again. I will forgo updating until I get confirmation that the issue has been fixed in later releases.

1 Like

I just marked the thread as unsolved again, as so many people still have trouble after trying felipeiise solution.
But because his solution seem to work at some systems, I added his solution to my initial post, so people who come here via search can find and try it easily.

Same issue on Ubuntu 20, I also tried felipe’s answer but i did not succeed

Looked like it’s a combination of chromium and plasma? I am on gnome 2 (Ubuntu mate) and I have not experienced this issue.

I don’t use Plasma and I’m having the same issue. Debian Sid, i3, no Desktop Environment, this started a week or so ago.
Version 1.34.80 Chromium: 97.0.4692.71

1 Like

The github issue quoted is actually for bookmarks on the browser bar… this issue is tabs. But who knows: maybe they’re related.

Hey @fbicknel, thanks for checking!

Just for clarity. The issue listed is for tabs. The scope of the issue widens to any drag and drop functionality in the browser which would also include file uploads, captchas, bookmark drag and drop, etc…). It seems to primarily affect QT-based desktop environments since the GTK workaround does not provide functionality back.
relink here: https://github.com/brave/brave-browser/issues/20386

2 Likes

Keyboard and mouse workaround until update:

• Move tab left: Shift+Ctrl+Page Up
• Move tab right: Shift+Ctrl+Page Down
• Move tab to new window: Right-click tab > Move tab to new window
• Move tab to existing window: Right-click tab > Move tab to another window