More trouble with Brave's TOR window/tabs

I have been reporting problems with TOR tabs/windows.
Today I can add another:
I noticed that my already-open, previously-functional TOR window was displaying a message that it was ‘Disconnected’.
I went to Settings to toggle the TOR setting (the standard ‘fix’).
Instead of fixing, however, the TOR window crashed and burned.

The feature could use some attention, Brave Team.

Mac OS Mojave (10.14.3)
Brave Version 1.47.149 Chromium: 109.0.5414.46 (Official Build) beta (x86_64)

1 Like

Hello there @mk7z please accept my apologies for this issue.

Can you please go to brave://crashes and if you have automatic crash reporting is enabled (Settings --> brave shields and privacy --> Automatically send diagnostic reports), please respond back here with the crash report ID

If Automatically send diagnostic reports is not enabled, ensure you click Send on these crash reports listed on the page, then reply here with the crash report ID.

Be waiting for your response.

Thanks, @Kevin_cc. The setting is ‘on’ but there’s no crash report.
Does the ‘crash report’ function work with TOR windows/tabs?

@Kevin_cc . . . Further evidence that all is not well with Brave’s TOR tabs.


This seems to happen only on the first try. No error message on the second one.

1 Like

Could you please try opening a new profile for Brave to see if the error no longer prompts? If they do load, try disabling your extensions to see if this is the cause of the issue.

You can open a new profile by going to Main menuCreate a new profile:

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

Thanks @Kevin_cc, is it just a matter of creating the new profile, then selecting it (if creating the new profile doesn’t automatically select it) and then opening a TOR window with the websites that have had the issues I reported?

As far as the extensions go, it would be odd for those to be causing the issue, since I’ve had the same few extensions for a long time, whereas the problem with TOR windows/tabs I’ve reported only began recently.

BTW, Protonmail support asked me to try opening its URL (in a Brave TOR tab) using a VPN.
Are there any VPNs that Brave recommends? (Free ones – or at least ones with free trials would be nice.)

1 Like

That’s correct, try loading the pages on the new profile while using TOR tab to see if the issue still happens there.


In the new Profile, Protonmail ( did load without the error message.
But Twitter ( still returned the error message.
However, as noted before, the error message only appears on the first attempt.
On the second attempt (usually done in a New Tab), the URL loads normally.

1 Like

twitter might not be the best with tor as far as i know unless you only access it from tor… idk. also google sites, or signing in. any other site should be alias only. the only issue i’ve had with brave so far is a respective tor page opening for sites like protonmail. I doubt visiting the site that doesn’t care or track will bat an eye at the same email being accessed from 2 i.p. addresses. perhaps there’s something i’m missing. there usually is so don’t be hard on me.

Thanks but Twitter has always been fine with TOR in my usage (mainly with the TOR browser).

This thread is about an issue that’s been occurring recently with Brave’s ‘TOR windows/tabs’ feature that had not happened previously.

That’s interesting, I suggest you go to your shields widget by clicking on the Brave logo > Upgrade connections to HTTPS > toggle it off. to see if Twitter loads properly on the first attempt.

@Kevin_cc Tried it just now, in a new TOR window (in Brave), with the original Profile, and with no changes to Shields. It worked without any issue.

It’s a headscratcher. I’ll monitor doing the same in the future and post whether the issue recurs or not.

I would of course not want to have to disable Shields when accessing Twitter in Brave. That would seem to negate any reason to use a TOR tab for Twitter.

@Kevin_cc But here it is, back again… (with . . .

This time it’s displaying in the URL line (apparently having auto-converted the former to it), but still returning an error message.


This time also failed on the 2nd try.
However, worked.


Issue with is intermittent.
Issue with is consistent.

@mk7z let me inform you that you will only be disabling the Upgrade connections to HTTPS option on your shields, as this may be returning this error when trying to access or as it seems the original URL is set to HTTP instead of HTTPS.

All the screenshots of the error messages show https:// in the URL line.

I don’t think I ever see http:// in the URL line anymore.

And I don’t believe that either Protonmail or Twitter would ever use it or allow it to be used.

Am I misunderstanding your post?

1 Like

@mk7z let me inform you that on the links you posted above this appeared as this when I copied the -, but if you still receiving the same error even after disabling Upgrade connections to HTTPS, try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

@Kevin_cc Thanks, I’m already using the beta version.

I"m not sure why you’re seeing http. The messages with screenshots earlier in this thread that include the URL line (as a separate screenshot) all display https.

I just opened both Protonmail and Twitter in TOR tabs and there were no error messages this time (“Upgrade connection to HTTPS” was active).

Was the issue being worked on in the past few days?

@Kevin_cc Well… back again.

URL displays https is in the URL line and “Upgrade connections to HTTPS” is on.


This was the same circumstance in which my access earlier today (reported in prior post) was successful. The site loaded without error message.

1 Like

Hi again @mk7z please try turning that setting off while you load those pages to see if you no longer get that error message.

@Kevin_cc What I am finding now is that when I open a Brave TOR tab, the Shields icon is greyed out and clicking on it has no effect

As of the current session:

When I then entered the full protonmail URL ( the site loaded normally.

And when I entered (without any prefix), it also loaded normally.

And when I then entered only – which usually results in the error message detailed previously – that now works also.

My impression is that the issue is intermittent and I don’t know what triggers or fails to trigger it.
The only other explanation I can think of is that Brave has been working on it and doing something to enable the sites to be loaded without having to disable the https setting in Shields.