Private Window with Tor always shows as Disconnected - Tor Browser works fine

Recently, Private Window with Tor only ever shows as Disconnected. It used to work fine up till a couple of weeks ago. I installed Tor Browser and it works fine, so there is no network or OS restriction on using Tor.

I am running Brave Browser Version 1.59.124 Chromium: 118.0.5993.117 (Official Build) (x86_64) on macos 14.1 Sonoma. I only noticed this after updating to macos 14, and I think there have been at least 2 updates to Brave Browser since the last time I used Private Window with Tor.

I have tried disabling then re-enabling Private Window with Tor in settings, but this has not fixed things.

I noticed someone else posted a similar question today (without much info - but they got a reply asking for more info - grr), so I thought I’d make my question more complete.

brave://tor-internals/ returns the following:

General Info tab

Tor version:
Tor process ID: -1
Tor Proxy URI:
Tor connection status: Disconnected
Tor initialization progress:


Completely empty

Tor Control Events

Also completely empty

I can access fine from Brave.

Update : checked in my Cloudflare Zero Trust logs - they have started blocking in their DNS blocking which must have changed recently. It is under the Security Threats list. I have whitelisted it, so hopefully that will resolve things soon.

Update 2 : That seems to have fixed it!

You have indeed found the problem. Cloudflare categorizes the domain, which we use to host the tor binaries needed to make private windows with Tor work, as Anonymizer:

It seems like that category might be blocked by default in that service.