Brave not loading pages like uniswap.org


Description of the issue:
How can this issue be reproduced?

  1. When I go to pages such as uniswap.org and polycat.finance, brave will not connect to my metamask wallet. On uniswap, it doesn’t even load the app, it goes to a blank page and wont load the page fully. I’ve tried reinstalling brave to no avail. I previously was able to use brave on all crypto sites and had no issues connecting to my wallet. On uniswap one time I got an error about web3.

Expected result:

Brave Version( check About Brave): v 1.27.109

Additional Information: Metamask v 9.8.2

@sig7,
Thank you for reaching out to us with this. Can you please tell me the OS version you’re using?
On my end, I’m able to both see the charts page and connect my wallet without any issue. Note that I connected my Brave wallet rather than MM, but it should work all the same.

Can you try going back to the site and try both viewing the charts and connecting a wallet and if/when you get the same issue, open the dev tools console window and share any output that appears there (a screenshot would be fine)? In case you’re unaware, you can open dev tools by going to Menu --> More tools --> Dev tools --> [Console]

Sorry for interrupting the discussion between both of you, just wanted to let you know users have been reporting issues with that MetaMask extension.

Thought I would share with you so you guys can verify whether the issue is related to it.

1 Like

@Rethanis,
Appreciate the heads up

1 Like

My iOS is 11.4 big Sur. Heres a screenshot

Seems like the github is the same issue I am facing, but there is no solution there yet that I saw.

@sig7,
In that last image you sent, can you please repeat the steps and select/share the Console tab?
image


Screen Shot 2021-07-28 at 14.02.33

@sig7,
Can you please go to Menu → Settings → wallet and check to see if you have MetaMask selected in the Ethereum provider for using Dapps dropdown?

Yes I do. Ive used brave for months without a problem, this just started happening last night.

So I uninstalled metamask, and reinstalled it and now it seems like everything is working…

@sig7,
Interesting – I’d just reached out to the team about this when you sent that reply. Please keep an eye out and if the same issue presents itself again (or a different one) let me know.

Ok thank you for your help.

I am having the same issue. If I disable Metamask, it works. Works fine in Chrome.

You could try @Luckys’ workaround from the thread below. Worked for a few users.

SOLUTION: as of 08/31/2021 for Brave Version 1.28.106 Chromium: 92.0.4515.159 (Official Build) (Windows OS 64-bit), MetaMask extension Version 10.0.3, and Brave Wallets extension Version 1.0.32

Preface and Background:
I had the exact same problem tonight when I wanted to check out a potential IDO in Brave Browser. After about 45 mins of head scrathin, this seems to work every time (regardless of my Chrome extensions or the settings in my Chrome Browser)

Brave Wallet (i.e. Crypto Wallets extension) is a fork of MetaMask itself. And when two MetaMask extensions are active at the same time (even if they’re forks of one another), they may malfunction - much like how injecting jQuery into a web page twice can cause front end design and functionality problems. This is why MetaMask throws the "MetaMask detected another web3. [...]" error as a security measure. After all, a malfunction for web design is one thing, but we’re dealing with finance here. Keeping your Secret Keys (seed phrases) safe is top priority for any web3 extension, so it’s smart to throw an error rather than let anything bad happen.

So… as long as Brave’s “Crypto Wallets” extension is active at the same time as MetaMask, the two will interfere with one another and throw the error which leaves Uniswap and all other Dapps with a blank page or an error message for you on the page.

So here’s the solution:
Inside of Brave, all you need to do to get MetaMask working is to Extensions > Manage Extensions > Crypto Wallets > Toggle OFF this prevents the two from interfering with one another. On the same note, if you ever want to get Crypto Wallets to work, then you’ll need to disable MetaMask.

Hope this helps!
P.S. To the Devs and @Mattches : Maybe you could:

  1. add a module/function that auto-disables Crypto Wallets on a Dapp page if MetaMask is active?
  2. OR perhaps you could find a way that Crypto Wallets and MetaMask can share data with one another or unidirectionally from Brave to MetaMask using the appropriate prompts to the user?
  3. OR you could just return an alert.(errorMessage) function so you can let everyone know what to do. Just an idea

EDIT #1:
I actually found it’s easier (and more convenient) just to change the Crypto Wallets extension Settings for site access > This can read and write site data > Toggle OFF: "On all sites" > Toggle ON: "When you click the extension" - This way, you can keep Crypto Wallets active; however, it will only interfere with Dapps that use your MetaMask extension IF and ONLY IF you click the Crypto Wallets extension and then reload the page. :nerd_face:

1 Like