Metamask Plugin Not Connecting to External Services

Description of the issue:

Since I enabled the native cryptocurrency wallet in Brave, I am no longer able to connect my Metamask account accessed via the plug-in to various external websites. The Brave native cryptocurrency wallet looks very much like the metamask UI, so perhaps they are clashing?

Exact URL of the website in question:

**Did the issue present with default Shields settings?

Yes, I tried with shields both up and down – the same error.

Does the site function as expected when Shields are turned off?


Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):


Does the site work as expected when using Chrome?


Brave version (check About Brave):

Version 1.2.42 Chromium: 79.0.3945.117 (Official Build) (64-bit)

More or less, yes, @tonyg99. Brave’s Crypto Wallet is MetaMask fork. And it’s a known issue if you have both enabled.

For now you can disable CW under Settings > Extensions. The fix is coming.


1 Like


Presumably another option would be to import my Metamask wallet into the Brave CW, and then remove the Metamask plug-in — would the external sites (Mintr, Kyber etc.) recognize the Brave CW as a Metamask wallet?

I’m having problems even after disabling Crypto Wallets. I still cannot use Metamask with any of the 3 dApps I tried. Happy to provide more debugging info if the cause is not known.

Try restarting the browser. In fact, why not try restarting the whole computer! :slight_smile:

Metamask & Mintr are both working in Brave for me now.

Sigh…that worked. Software…


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.