[Metamask & Ledger] Connect hardware wallet does not work

Description of the issue
I can’t connect my Ledger Nano X hardware wallet to Metamask when using Brave.

Steps to Reproduce

  1. Click on Metamask extension icon and then “My accounts”
  2. Click on “Connect Hardware Wallet”
  3. Select Ledger & click on “Continue”
  4. Wait

Actual Result
At step 4, it keeps displaying “Looking for your Ledger” in loop.

Expected result
At step 4, I expect some messages popping up to connect to the Ledger accounts.

Reproduction rate:
100%

Software Versions

  • OS: Windows 11 Pro 21H2
  • Brave: Version 1.35.103 Chromium: 98.0.4758.102 (Official Build) (64-bit)
  • Metamask: 10.10.1
  • Ledger:
    • Secure Element : 2.0.2
    • Microcontroller: 2.30
    • Bootloader: 1.16
    • Ethereum app: v1.9.17

Additional Information

  • The Ethereum app is opened during the attempts
  • Although webHID is the recommanded connection option, and as it was not working, I’ve tried the 3 options from Metamask (Ledger live, webHID, U2F)
  • Brave Wallet Setting default crypto wallet is set to None

  • As it works fine with Firefox & Chrome and as I did not find lots of related threads around I may have something not correctly configured in my Brave setup. But I can’t figure out what goes wrong. So please also find attached my extension configuration page in case something there could be wrong:
  • It works fine with Rabby wallet
  • I’ve contacted Ledger support but they have no clue about it.

Any help welcome,
Cheers!

Hey there, one thing i saw on your wallet settings screenshot, you need to change Default cryptocurrenty wallet from None to → Prefer Plugins. If you havent already tried that. That may fix yours

I’ve had the exact same problem (but on Linux) for about 8 months now.

Try to connect Ledger through metamask and it just spins. Even in metamask settings, if I set to “WebHID”, thats the only time I get a box popup showing my ledger device. But if I click on the “Ledger - paired”, and click Connect, it just spins.

I am honestly not sure if this is a Brave issue, or a metamask issue??? However, I’m leaning toward Brave issue, since the metamask plugin is the exact same on Chromium and Brave.

Metamask works fine, except Ledger in Brave. Ledger through Metamask works fine for me in Chromium.

In searching this forum, it looks like these metamask/ledger connect issues, dont hardly get any responses.

Is there any way to get support for this issue??? I’ve tried posting on reddit, github, and now I’ll post here. I’d had this problem for probably 8-10 months, and its only with Brave for me.

I’ve tried

  • clearing cache
  • Changing wallet to (prefer plugins)
  • tried metamask in private mode
  • tried uninstalling, reinstalling metamask
  • tried all 3 options in metamask (webhid, ledger live, u2f)
  • and more

I will create my own thread as well. Sorry for hijacking your thread. I just figured this would also bump it and show theres other people with the same problem as well.

Well, I’m quite happy to find team mates as I was really feeling alone. :slight_smile:
So not only you’re not hijacking this thread, but I would rather say: welcome home. :slight_smile:

I’ve just tried changing the default crypto wallet but with the same result.

Taking a look at this issue — appreciate the detailed report. Hope to have more information for you soon. On my end I was able to connect my Ledger to Brave wallet using the normal flow and I’m not aware of any open issues with this.

Thanks for your patience.

@Malombres,
Some low-hanging fruit here — can you confirm whether or not your Ledger device firmware is fully updated?

Also wanted to note that I originally thought you were connecting to Brave wallet directly but it appears you’re trying to connect via MM extension. That said, upon testing, I am also able to connect my Ledger device to MM without any issue.

Hi Maatches, thank you for your feedback and time.
Yes I can confirm the Ledger Nano X is up to date. I also regularly software update the various items (and often redo the test, just in case).

And yep, I try connecting using MM. I’m not surprised you do not reproduce it as I’ve not found similar cases during my researches so I guess I’m probably in a corner case, unfortunately for me.

It’s not blocking me as it works fine on 2 other browsers. But Brave being my main one, I would prefer using it for this too.

Something I’ll try is using another computer, hoping it will work so I’ll be able to check setup differences.

Let me know what you find out — in the meantime we will try and reproduce on our end and see if we can figure out what’s going on. You might also try setting up MM and connecting your Ledger in Brave using a fresh profile to see if this makes any difference.

I have this same issue. Looking forward to a resolution. Thanks.

Hi there,

Sorry for the delay in answering. I’ve juste done the tests and it works fine:

  • On another computer (same SW config, just another computer with Windows 10 pro)
  • With a fresh profile on the same computer!

So I tend to think there is something I (or an application) changed in my Brave setting that leads to this.

Now, how to find it…it’s another story.

Note that in the environment where I have this issue on Metamask, it works fine with Rabby wallet.

Cheers,
Vincent.

Hey Yall,

This is happening to me as well. I just did a fresh Windows 11 + Brave + Metamask install and had it happen only then. I tried connecting via the standard method and LedgerLive with no avail. I’m wondering if it could be related to the chromium security update from a few days ago?

I did manage to get it working using the LedgerLive API. Once it was connected via that method, I switched it back to the standard method and it started working.

Thanks for sharing the knowledge.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.