Ledger wont connect through Metamask, just spins in Brave; Chromium metamask works; Brave wallets work

I’m on Linux, but i’ve seen Windows users also report this.

I’ve had this problem for about 10 months or so.

Brave version:
Version 1.35.103 Chromium: 98.0.4758.102 (Official Build) (64-bit)
. I’ve had this problem for along time, and no brave updates have changed it.

Try to connect Ledger through metamask and it just spins. Even in metamask settings, if I set to “WebHID”, thats the only time I get a box popup showing my ledger device. But if I click on the “Ledger - paired”, and click Connect, it just spins.

The ONLY time it prompts me with the connection box that shows “ledger - paired”, is if I change the metamask advanced setting to “webhid”. But then it just wheel spins. And if I try to go through “connect hardware wallet”, connect to Ledger, I DO NOT get the connection box, and just get spinning wheel.

I am honestly not sure if this is a Brave issue, or a metamask issue??? However, I’m leaning toward Brave issue, since the metamask plugin is the exact same on Chromium and Brave.

My Ledger DOES connect to Brave wallet! (just not through metamask)

Metamask works fine, except Ledger in Brave. Ledger through Metamask works fine for me in Chromium.

In searching this forum, it looks like these metamask/ledger connect issues, dont hardly get any responses.

Is there any way to get support for this issue??? I’ve tried posting on reddit, github, and now I’ll post here. I’d had this problem for probably 8-10 months, and its only with Brave for me.

I’ve tried

  • clearing cache, cookie, browser data
  • Changing wallet to (prefer plugins)
  • tried metamask in private mode
  • tried uninstalling, reinstalling metamask
  • tried all 3 options in metamask (webhid, ledger live, u2f)
  • tried all the help i’ve found on reddit , here, and Brave support pages for metamask and ledger
  • tried different browser (chromium works)
  • changed ledger settings (enabled blind signing)
  • Ledger Live, installed apps, and Ledger are completely up to date.
  • tried every usb, metamask, ledger setting I could find in Brave settings, metamask settings, plugin settings, computer settings
  • My Ledger DOES connect to Brave wallet! (just not through metamask)

I dont recall if Ledger has ever worked on Brave for me through metamask.

I wonder if there are missing settings on my Brave version? I know theres no “about:config”, and so theres hardly any settings in Brave! I wonder if theres some browser setting in Chromium that allows the connection to work, that ISNT in Brave???

Thank you!

I have the same issue, except I’m attempting to connect MetaMask to Trezor through Brave.

I am having the same problem, even tried on different laptops (windows/mac). Anyone been able to solve this?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.