Metamask Extension not popping-up when prompted

For a few months I have an issue with metamask extension. Usually when prompted, the metamaks window was popping-out to confirm the transaction, or for any other action. Now, I have to manually press on the extension for it to open up. Other wallets work just fine, the issue is with metamask only.

I tried to disable/enable - did not help.
I don’t want to remove extension completely and then instal it back as I’d have then to manually add chains, coins, etc., which is an extensive work.

Could not find any setting related to that in the metamask itself so maybe you guys know if it’s a Brave issue and how to fix it.

Thank you and hope you’re having a great day!

@Chirumba what is your settings like for Web3 in Brave? brave://settings/web3


If you haven’t done so, you may want to make sure that they are set for Extensions for default. If it’s not on that, then clicking on stuff likely would be trying to default to your Brave Wallet.

Thank you for your reply. The default for me was the first option “Extension (Brave Wallet fallback)”. This issue occurs just with Metamask while other wallets automatically open when prompted.

Thanks for the reply @Chirumba. As it’s another day and I’m more awake, I should have realized that was the case based on your initial details. I mean, you said it was going to the extension but the only change is it wasn’t giving you the pop-out prompt. So I apologize for essentially just spinning our wheels.

I am kind of curious if this is a change within the browser itself or if it relates to Metamask, also if there are any settings that can be changed. I’m going to tag in @Evan123 and @Mattches to see if either might have a better handle on this. Hopefully they’ll be able to get back to you within the week.

Do you have more than two wallets installed, aside from Metamask and Brave Wallet? Other wallets may be interfering with your MetaMask prompt.


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.