Massive performance issues with Brave Browser

Description of the issue:
Since I have installed Brave the first time last year (before I used Chrome) I encounter performance issues noticeable when watching videos (not only youtube). The videos have frametime issues / low fps especially as soon as the videoplayer overlay is in front of the video or as soon as I work in parallel on a different browser-tab right until to a point where the video is completely stuck and does not continue at all. Also scrolling through some types of websites (e.g. my nextcloud website, it seems that its related to all kinds of websites which use animations (javascript / css ).

Also on anime.js the animations are massively lagging when I start scrolling (very low fps). With the developer tools it’s noticeable how kind of renderer / drawer functionality suddenly eats much much more time than with other browsers (during scrolling). I reproduced this where the screen is not updated at all but the browser is performing a scroll (see the super long commit bar):

None of these issues I have with Edge and also not with Chrome and Firefox.

How can this issue be reproduced?

  1. at least on anime.js scroll slowly and watch if the animations get stuck / slow framerate
  2. open youtube and notice that everything takes seconds to load properly (also the startpage)
  3. watch a youtube video and hover onto the video with the mouse (so that the overlay is visible) and the frametimes suddenly are inconsistent

Expected result:
The framerate is consistent and always 60fps

Brave Version( check About Brave):
Version 1.49.128 Chromium: 111.0.5563.110 (Offizieller Build) (64-Bit)

Additional Information:

  • Performed several re-installations
  • Cleared browser cache already
  • Tested with and without HW Accel (the issues differ with HW accel ON/OFF but are not solved with both settings)
  • Uninstalled Chrome Browser
  • Do you need my HW setup?

Which website specifically @Diluvian

I’m assuming; They look similar. a dynamic site can impact performance stats.

  • Chrome:

  • Brave:

Hi @fanboynz. Sorry for being not detailed enough:

  1. Yes its
  2. Use middle-mouse button to use the scroll-via-mousemovement feature (don’t know how it’s actually called) and start slowly scrolling
  3. on my side with brave, the website is scrolling but the contents (animations) are not updating anymore or only with very slow framerate. that is what you see on my initial screenshot. The big “green” bar with the name “commit” represents the state where the animations framerate reached ~0fps

here again for comparison:

Edge: (no inconsistencies noticeable, even during scrolling)

Brave: (see the inconsistencies in the middle, thats the area i’m scrolling)

Is there a static site that shows this?

On a static site I notice that the frametimes vary and that I can see stuttering during scrolling



I’m not sure if this performance tracker in any kind is the right tool to analyse my issues :).

Additional Info:

  • It makes no difference if I deactivate the ad-blocker
  • My GPU drivers are up to date (RTX2080 Super)

Can I somehow deliver more information to you so that you’re able to suggest me further steps I shall perform to get closer to a solution?

  • can someone test on his machine and tell me if the animations get stuck/not fluent anymore when scrolling very slow? (using middle mouse-press and drag to scroll method)

  • interestingly, I tested some more chromium based browsers and only vivaldi (which also supports privacy settings such as ad blocking) has the same issues even though I deactivated the ad-blocking (same issue on, same issues on youtube (e.g. starting 3 streams simultaneously will cause severe playback troubles)

Unless the GPU Acceleration is disabled, I see no issues. I also have a 2080 Super. isn’t a static site. can’t be benchmarked reliabled as each run will be different because of the animation interactions are different for everyone and each run.

For non-static, with Hardware acceleration + 2080 Super + 1440p/144hz monitor: shows 130-144fps here. Easier to benchmark when it shows an fps in the corner.

(edit: removed the framerate lock in brave browser, lowest fps is 57fps) 57fps with 2080super, 1440p@120hz, i5 8600k, hardware accel on on three but also the same framerate on edge browser which runs significantly smoother so this part of the browser may not be the issue.

There is a framerate lock? Tested with default settings in Brave Beta & Nightly. getting 130-144fps. Minimal drops of maybe 1-10fps if move the mouse around quickly.

Yes I have to add the following lines to the shortcut, to remove framerate limiting:
–args --disable-gpu-vsync --disable-frame-rate-limit

Version: v1.50.114

For what it’s worth, I think I’m seeing similar issues. My best guess is it is some combination factors from both my user profile and the HW acceleration function.

Steps to reproduce for me:
brave://settings/system - HW acceleration: enabled (default)
brave://flags - nothing set (default)

  1. Open and run in one window on my second monitor (I’ll call this window 2). (Must not be minimized)
  2. Open brave://flags as a test site on my main monitor in a separate brave window (I’ll call this window 1). Drag the scroll bar quickly to the bottom or midway, but don’t release the mouse button, it will take a noticeable amount of time for the page to render. About a second to load.
  3. Open this exact thread (Massive performance issues with Brave Browser - #11 by Diluvian) as the test site in window 1. Drag the scroll bar around without releasing, the site won’t render at all until you release the mouse.
  4. Minimize the Pandora window. Scrolling now works fluidly and perfectly.
  5. Unminimize the Pandora window, rendering this exact thread site no longer occurs until I stop scrolling.

(not shown is the cursor dragging the scroll bar with the mouse button still held down)

More extreme/different test:

  1. Leave Pandora open and running on window 2.
  2. In window 1, open this YouTube video ( Manually select 4k resolution for the video and put it in theater viewing mode.
  3. Right click in the video window and enable “stats for nerds”.
  4. Skip around the video in to unbuffered sections. Note how buffer health will quickly refill but in my case the video will remain buffering with the spinning circle for 30 seconds+, possibly indefinitely. The fact that buffer health is fine indicates it isn’t a network issue.
  5. As soon as a minimize window 2 with Pandora and move the window focus back to window 1 with YouTube, Youtube will unfreeze and start playing. (This is what makes it feel like some conflict with hardware acceleration.)
  6. Unminimzing Pandora again causes the video playback to freeze.

Sometimes the YouTube/Pandora test will replicate the issue, but sometimes it won’t even under the same scenario. I haven’t been able to reproduce the scrolling issue or the YouTube issue in a guest mode, even with Pandora open and running, which makes it feel like a user profile issue.However, even if I disable every single extension on my main Brave profile, the YouTube stuck buffering issue and the not-rendering-while-scrolling issue remains.

I can’t be bothered to recreate my entire Brave profile in an attempt to fix this. Clearing my browser cached data doesn’t change anything, and I’m not going to go through the pain of clearing my history and cookies unless someone can tell me precisely why those might be causing these specific issues.

Unsuccessful workaround: Setting brave://flags - Choose ANGLE graphics backend to OpenGL. Scrolling issue remains, albeit possible just now very slow instead of not rendering at all? Minimizing Pandora now seems to make no difference? YouTube also might be working better but it’ s hard to tell since I can’t reliably reproduce the issue. The issue might reproduce better with Pandora open on window 2, YouTube running and playing the video in a background tab of window 1, and then attempting to scroll this thread in the main tab of window 1.

Partial workaround: Disabling HW acceleration seems to fix most things, but now I’m getting dropped frames when scrolling through this thread.

Brave Version:
Version 1.50.114 Chromium: 112.0.5615.49 (Official Build) (64-bit)

Computer Specs:
AMD Ryzen 5900X, RTX 4090, 32GB RAM, NVMe SSD

Assuming HW Acceleration is enabled, Update GPU drivers to the latest nvidia version? also possibly test an older driver version

I’m still on 528.24, no issues yet on Pandora

@tinfever Thx for also doing some tests! Unfortunately I have no access to from germany so I’m not able to replicate your issues.

Regarding the Youtube video: On my side it’s already sufficient to play it at 720p resolution on a second screen while this forum is openend in parallel and the video has major stuttering issues (short black screens and music stops for some miliseconds almost every second). But I am also able to somehow cause that infinite loading/buffering bug (open 3 youtube videos in parallel and play around a bit).

I on my side have the latest GPU drivers installed. I may try a complete clean reinstall of the drivers.

Ah yeah … that did the trick finally! :watermelon:

@tinfever pls also try to update your nvidia drivers via clean installation (you can check that option during the installation process)

EDIT: Still working after reboot, yt videos now directly start at maximum resolution (was not the case before) and I can run the 4k video 5 times in parallel without any issues. That seems to be the solution at least for me!

A clean install/update to Nvidia driver 531.61 may have fixed it for me too. I’m not 100% sure yet though. I’ll try to report back if the issue reoccurs.

Since the clean install removes all of the Nvidia settings, I wonder if somehow one of the custom Nvidia settings I was using was causing the issue. Something like G-Sync, vertical sync on, framerate limit, low latency mode set to ultra, etc.

Okay, I’m not sure it’s actually fixed.
Here is a great static page that can make things grind to a halt:

Open that page and then have the development tools in the browser open as well (check the box to disable caching) , then do Ctrl+R on the webpage to reload it. Try to scroll around rapidly while it is still loading.

The scrolling was rendering very slowly during scrolling for me, so as a test I disable HW acceleration and restarted the browser when prompted, it was then much faster and smoother to scroll around while it was loading. I then re-enabled HW acceleration, restarted the browser, and now it seems okay. Of course I try it again a minute later and the very-slow-rendering-while-scrolling issue has returned. Then I start to setup a screen to GIF capture and it’s working fine. (All of this testing was with Pandora open on another screen)

This is just silly.

Managed to capture it:

there is a lot of images on the site, even on my fibre connection it took a while to load. Loading the images while scrolling. Can you test in private window mode? Or failing that Brave beta. Don’t change any flags or settings.

I have absolutely no issues with scrolling, even during loading (used to slow down the network speed so i have time to try it out because I also have fast connection and website builds up very quickly)

→ Are you sure you really did a clean install of the GPU drivers? Maybe you try one of the more “advanced/non-standard” clean installs which are suggested on the web if the standard-clean install does not work. I had the absolute same issues as you had and it fixed it for me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.