Make Default button doesn't do anything

I want to make Brave the default browser but the “Make Default” button doesn’t do anything. I am using Linux Mint 23.1 with the Cinnamon desktop. I saw a couple of other threads from a year or two ago on this very issue without any real solution. I get regular updates but this issue seems not to get fixed. I would rather Brave come up when clicking on a link instead of Firefox.

“Cinnamon” desktop - try this: Menu - 'Systems Settings' (Control Center) - Preferences - Preferred Applications

Internet | Web is at the top of my list. The drop-down menu should offer Brave (and any other installed browser).

Adding: I’ve used this to change other ‘Preferred Applications’, not the default browser. YMMV.

I’m using Debian. Though Mint is based on Debian, I don’t know if the different implementation will affect you.

Yes, that was actually what I needed to do. Thanks.

I’m glad that worked.

Consider indicating the problem was solved (click ‘Solution’) which will help others searching this topic.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.