Brave Is not your default browser bug


Description of the issue:

When ever I launch Brave it says that it is not the default browser when it is the only browser that i have installed.

How can this issue be reproduced?

1.Quit Brave
2.Reopen

Expected result:

For it to not say “Brave is not your default browser”

Brave Version:

Version 1.16.28 Chromium: 86.0.4240.30 (Official Build) nightly (64-bit)

Additional Information:

I am using Arch Linux and the Nightly release of Brave.

Hello @Programador

using single browser does not make it the default
so go to
brave://settings/
make it default hope that help and have a nice day :slight_smile:

i have done that and it still doesnt work

let me ask for someone from the team to help you @Aa-ron

and notice it still weekend so you will get your response starting from tomorrow

and have a nice day both of you

what u use gnome kde or what?

or try use xdg-open and set default browser brave

im using kde and bspwm the same thing happens on both

u try it https://userbase.kde.org/System_Settings/Default_Applications?

but i have

$ xdg-settings get default-web-browser
brave-browser-beta.desktop

also u can try it

xdg-settings set brave-browser.desktop

This is a known issue on Arch (and is not something we can fix since it’s a community-maintained package) but there is a possible work-around: https://github.com/brave/brave-browser/issues/11032#issue-669481089