Unable to set Brave as Default browser. Linux Mint 21.1

Unable to set Brave as the default browser. I have read all the solutions but none of the fixes seem to work. Using Linux Mint 21.1 Cinnamon, with both latest Brave and Beta. Brave 1.52.122

  1. Start Brave
  2. Bar with Set as Default appears.
  3. Click on it, check settings in Brave and preferred browser in Linux settings and still not default.
    I also tried deleting all other browsers, didn’t help.

Brave becomes default browser.

Brave Version 1.52.122 :

I also tried running the command from the terminal that I found in a help area, still nothing. Every time I get an update I hope this will be fixed. No luck yet.
Kernel: 5.15.0-73-generic x86_64 bits: 64 compiler: gcc v: 11.3.0 Desktop: Cinnamon 5.6.8
tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy
Type: Desktop System: Hewlett-Packard product: HP EliteDesk 800 G1 SFF v: N/A
serial: Chassis: type: 4 serial:
Mobo: Hewlett-Packard model: 1998 serial: UEFI: Hewlett-Packard
v: L01 v02.57 date: 12/11/2014
Info: quad core model: Intel Core i7-4790 bits: 64 type: MT MCP arch: Haswell rev: 3 cache:
L1: 256 KiB L2: 1024 KiB L3: 8 MiB
Speed (MHz): avg: 3911 high: 3980 min/max: 800/4000 cores: 1: 3774 2: 3916 3: 3917 4: 3980
5: 3876 6: 3887 7: 3971 8: 3974 bogomips: 57468
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
vendor: Hewlett-Packard EliteDesk 800 G1 driver: i915 v: kernel ports: active: HDMI-A-2,VGA-1
empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0412

Someone asked the same thing in the Linux Mint forum in March and did not get an answer, but that made me curious. (BTW: my DE is MATE, not Cinnamon.)

On my main machine (LM 20.3), I use almost exclusively Brave and the system’s behaviour suggested that it was set as the default but my “Preferred apps” settings showed a blank field for the “Web browser” category and offered only Chromium and Midori as possible selections. I did not touch that setting but instead went in Brave’s own settings and clicked on “Make Brave the default browser” (which I had not done upon installation) just to see if it would affect what “Preferred apps” shows. It did: “Chromium” is now the selected default browser! :weary:


At this stage, it looks like Brave is quite deficient with regard to setting itself as the default browser on Linux systems. (At least when Chromium is also present.)


On a test machine, with LM 21.1 / MATE and where Chromium is also present, the Web browser category in the “Preferred apps” screen shows that Brave is the default, along with Pale Moon as the only other possible selection, not Chromium! :roll_eyes:

So maybe it’s Linux Mint that is deficient after all.

When you mention that you “tried running the command from the terminal”, what command is that?

Unfortunately, I didn’t save the commands. I found a series of sudo commands to clear out what Linux had as the default browser and then told the OS it was Brave. I copied them from online into a text note, then copied them one at a time into a terminal session. I then restarted Brave, but it didn’t work. Brave is shown as my default in my preferred programs. I don’t see a default programs option in Mint 21.1 Cinnamon. In the previous case, using the Brave beta seemed to be a work around, but there have been a number of Brave updates since then and the current beta doesn’t fix the issue. Since a previous beta did seem to fix the issue (with Mint 21.1), I would guess it is a Brave issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.