Cannot set as Default browser

Since upgrading to Linux Mint 21.1, I get the “Brave is not your Default Browser” bar. Clicking there, nor in Settings has any result. I still get the bar every time I open Brave. Any help?


Version 1.46.144 Chromium: 108.0.5359.128 (Official Build) unknown (64-bit)

1 Like

Have you gone into your system settings to select the default applications? I had a similar issue in Manjaro. I had to go into the system setup and change the default browser from Firefox to Brave.

Yes, I have. Preferred Applications is set to Brave. No effect. I still get the “Brave is not your default…” bar every time I open it and can’t set Brave as default there or in Brave Settings.

The other thing I did was to make sure that I set Brave as the default in the program itself.

You might also want to check if Brave is the default for .html and other web-related files.

As I wrote twice above, I have tried to set Brave as default by clicking on the alert bar, by going to Settings in Brave, and also by going to Preferred Applications in Mint 21.1. None of them set Brave as default. I waited until the next Brave update (1.46.153) to see if this has been fixed. Nope. I still get the “Brave is not your Default Browser” bar every time I open Brave.

Which desktop environment are you using in Mint?

I’m using Cinnamon. (adding to get to 20 characters)

1 Like

Well, this is weird. I am running this version of Brave (now 1.46.153) on three computers and two of the three show this problem. One, running Zorin 16.2 (gnome 3.38.4 on Ubuntu 20.04) has the same “Brave is not your Default” issue that cannot be corrected.

Another laptop, running MX-21.2.1 (xfce 4.16.0 on Debian 11) DOES show Brave as default with no problems.

Three OS, thee desktops, two on Ubuntu base that have the problem and one on Debian that does not. So…is this an Ubuntu issue?

1 Like

That’s possible. I run Manjaro and I’ve never had this issue before.

Another issue could be if it’s installed as a Snap file. That can cause issues for some people.

1 Like

Nope, none were installed as snaps. In Mint I had to install via Terminal, but MX and Zorin installed from their software managers. I’m stumped. Good thing it’s only a minor pain in the neck (or somewhat lower).

1 Like

Is anybody at Brave looking into this?

1 Like

Hello there @RockyRaab please accept my apologies for this inconvenience. Did you installed that Brave version from our official repository and not from the snap version?

On this computer, I used terminal commands that I copied from somewhere. It was months ago, so I don’t recall precisely. I have never used snap.

2 Likes

Hi again @RockyRaab, please try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

1 Like

I went to my backup/travel laptop running Zorin (details in a post above) to test this rather than risk it on my main 'pooter. The BETA version does indeed allow me to set Brave as default whereas the regular version on that same machine does not. If the BETA version will soon come out to replace the standard, I’ll wait to upgrade my main machine at that time. If it works there also, I’ll call this one solved. Thanks in advance!

Just got the update to Brave 1.47.171 and it does not fix the issue either in Zorin or Mint. Will wait (somewhat impatiently) for the update to Brave Beta which is 1.48.132.

1 Like

Hello @RockyRaab

sorry for not reading the whole comment

but how did you install brave

using the 5 command line from this link

or using snap

if you using snap then it’s most probably the issue

so install brave using the command line and see if it help

1 Like

You did not read the whole thread.

1 Like

When you set the Beta version to be your default Browser, did you have any extensions installed or you just set it after installation? If that’s the case you could try deleting any extension you may have to see if that solves the issue.

1 Like