MacOS 10.14 won't launch Brave browser stating it requires 10.13 or higher. Please help

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:

@Kchase Guessing you just downloaded Brave? You need Mac 10.15 or higher to use the newer versions of Brave. It should be advising you need 10.15 or higher, not quite sure it says 10.13 on yours.

In any case:

The last supported version for users on macOS 10.13 High Sierra and 10.14 Mojave is Brave version 1.57.64 and Chromium 116. After Brave Browser updates to version 1.58 or higher, macOS users will need to upgrade to macOS 10.15 Catalina in order to receive new browser updates.

You can see the notice that was given a while back to show that 1.57.64 would be the last version of Brave available for 10.14 or below. It also has a link to be able to download that version if you wish. Just keep in mind that outdated versions of Brave won’t be as secure and may not have many features, such as VPN, Rewards, etc. And Shields will be lacking capabilities and updates.

Key idea: you really should upgrade to 10.15 or newer for your Mac.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.