I need brave version below

Hello, I’m trying to get back to my previous Brave version. I am using Mac 10.13.6
I have been using Brave as my default browser, since 2018, and 2 days ago I clicked on “Update” link and downloaded the latest version, everything well with installation until I tried to open Brave and I get a message the version is not compatible with your operative system. I am looking for a previous version, but I can’t find it. I would like to recover my saved data, my settings and my information back again. Thx

Hi I believe the version is 1.57.64.
As noted at

Can be found at https://github.com/brave/brave-browser/releases/tag/v1.57.64

For macos
Brave-Browser-.dmg or Brave-Browser-.pkg will install this version.

Thank you ! It works perfectly

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.