Lag in scrolling and OS app switching

I see plenty of topics regarding lag but I have noticed three specific areas that behave the same and are present on different platforms.

-Browser shows blank screen (might be grey or white) for a second when switching between active windows. Basically after you don’t do anything in the browser for a while (minimized) then switch to it there will be a pause before the browser starts working again.
-Browser has noticeable scrolling lag when resuming actions like reading a page, getting to the end and then scrolling. Basically after you don’t do anything in the browser for a while (reading a web page) then scroll there will be a pause before the browser responds to scrolling commands (mouse wheel). After that pause the browser responds instantly to scrolling commands. This one is particularly annoying/jaring while reading and concentrating when you scroll and the browser takes an extra second or two to respond, sometimes it makes me lose my reading position.
-PDF scrolling in general is jerky and jaring

I can replicate this in both Windows 10 and MacOS.
Same brave sync account on both.

I’ve used many browsers lately like firefox and vivaldi in addition to the usual chrome and these problems don’t crop up there on the same computers.

Nobody wants to acknowledge this one?

For the record I’m using Bitwarden, Dark Reader, and Instapaper extensions. Same extensions I used in other browsers that don’t have this issue so I don’t think they are causing this.

But anyway it’s a Monday and I’m coming back to this work computer and this is a really annoying lag experience, very noticeable to me. I’ll be switching back to Vivaldi until this gets fixed.

I would highly recommend disabling the extensions in Brave and trying to see if this makes any difference in the behavior.

This is definitely not an overly common issue(s), although I do recall seeing a similar issue with the window going blank when switching between active windows from a while back that I’m trying to find now.

I would also suggest disabling Hardware Acceleration in the browser (Settings —> System --> Hardware Acceleration).

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.