Scrolling via mouse wheel lags sometimes

Normally, scrolling using the mouse wheel works fine for me. However, if I let the browser sit for a few minutes (not sure exactly how long), there is an annoying delay between using the mouse wheel and the scrolling action.

This might sound trivial, but it causes a mental jolt because the physical action isn’t matching the screen action. That often causes me to overscroll and then need to scroll back. Annoying.

This may be a duplicate of some other bug reports - it’s hard to tell from the descriptions.

Same here. I need no more than 30 seconds of waiting for it to happen. It happens every time I stop scrolling to read something in detail, and then continue scrolling.
Tested with release, beta and dev. All three have the same behaviour.
In the same machine, it does not happen with Chrome.

Just found a fix for the scrolling issue: Just disable this:

Stop non-timer task queues background

Stop non-timer task queues, in the background, after a grace period. – Mac, Windows, Linux, Chrome OS, Android
#stop-non-timers-in-background

in brave://flags. Don’t know if it will affect CPU/Battery usage, but I can’t live with the scroll wheel delay!

My bad :frowning: It didn’t fix the issue completely. Some pages (like wikipedia) still have the issue.

—edited—

This time I really found it!

My laptop has 2 GPU: Intel integrated and Nvidia GTX1050. If I run brave with the Nvidia, no matter what I configure, I get scroll lag after some idle time. If I create a rule in Nvidia panel forcing Brave to use the Intel integrated, it works flawlessly.