Keeps crashing on Mac latest OS

Not sure what to do. Happened the other day but temporarily resolved and thought it was fine but now it’s doing it again. I open it and immediately just crashes again

Hi @sj1919,

What version of Brave are you using?
Also, would you happen to be using Brave Release, Beta/Dev or Nightly?

@Aa-ron It says Version
I’m not sure of those three editions that you said. I believe the most general one

Can you try launching the browser from the Terminal using the --disable-gpu flag? This will launch the browser with the Hardware Acceleration feature disabled, which is known to cause crashes for some users. To do this:

  1. On your OS, open the Terminal application
  2. Once launched, enter the following command
open -a "Brave" --args --disable-gpu
  1. Hit enter, and the browser should launch.

If the browser stays open, go to Settings --> Additional Settings --> System --> Hardware Acceleration and ensure that this option is toggled “off”. If the browser crashes again as before, please let us know and we’ll continue further troubleshooting.

@Mattches ok that seemed to work, at least for now. I have turned off that Hardware Acceleration Feature now, which was indeed enabled, and re-started the browser again after. So far so good.

That’s excellent news – please let us know if the problem resfuraces.

@Mattches Unfortunately it has now crashed again this morning and the same problem is happening where I open it and it immediately crashes.

And launching with Hardware Acceleration disabled no longer works as it did before?

@Mattches I do not want to keep going in cycles and have to do that every day.

I wouldn’t either – and I’m not asking you too! I just want to know if that does still work. If it does, it means that the browser may be resetting the HWA value back to on after the browser is closed, thus causing the crashes again.

@Mattches Ah, ok. I did it again and it is working (for now) but I don’t know if it will crash again

Can you, with the browser now open, go to Settings --> Additional Settings --> System --> Hardware Acceleration and note whether or not this option is toggled “on” or " off?

If toggled “on”:

  • Toggle the option to “off”, then relaunch the browser when you’re prompted.

If toggled “off”:

  • Toggle the option to “on” but don’t relaunch when prompted.
  • Toggle the option back to “off” and if you still see the prompt to relaunch, do so now.

The idea here is to get the browser into a state where it launches and HWA is already turned off – IIRC, when you launch via the Terminal, the additional flag (--disable-gpu) does not persist through sessions. Which may explain why your browser is crashing again – the setting didn’t persist, so now it’s in the same state it was before launch via Terminal.

So if you can get the browser to relaunch with that option disabled, you won’t have to deal with the issue again.

@Mattches It was off and so I did the togging on and off again with the instructions you mentioned, and it did not give the prompt to relaunch again after turning back to off.

And if you toggle it on/off, then close the browser anyway, does the toggled Setting persist?

@Mattches Yes, the same thing happens after closing the browser anyway.

Can you try creating a new browser profile (Main menu --> Create new profile) and then, in the new profile window that appears, going to Settings and disabling Hardware Acceleration? Then close the browser and launch again.

@Mattches Did so and no difference.

To confirm, you did open the newly created the profile after creating it, disabling HWA, and closing?

@Mattches Yes. And also my browser randomly just crashed yet again right now.

@Mattches and the Terminal action isn’t even working right now to re-open it either. It does so but then immediately crashes.

1 Like