Brave browser crashes after using it for few seconds


Description of the issue:
Brave browser crashes after using it for few seconds on macOS 10.15

How can this issue be reproduced?

  1. Download latest version of the browser and install it on macOS 10.15
  2. Go to google.com or any other site, after few seconds it crashes

Expected result:
Browser should not crash

Brave Version( check About Brave):
1.10.97

Additional Information:
I have been seeing this issue since last updating to 1.10.97

1 Like

@testuser3130,

:point_up: Are you saying that you “haven’t seen this issue until the update to v1.10.97”? Or are you saying that this issue no longer occurs after updating to v1.10.97

If you’re still encountering these crashes, it very well could be due to having Hardware Acceleration enabled by default. Can you try running the following Terminal command to launch the browser with HWA disabled and see if the browser stays open?
Simply open the Terminal application on your system and enter this command:

open -a "Brave browser.app" --args --disable-gpu

I tried with the above command, it still crashes. By the way, I am seeing this after updating to 1.10.97 and didn’t have it before.

@testuser3130,
Thank you for confirming this for me. Can you check and make sure that you have crash reporting enabled in Settings so that the team can go through the reports and try to identify the issue? You’ll find this in Settings --> Privacy/Security --> Help improve Brave's features/performance.

Additionally, would you mind downloading our Beta build and see if the Beta crashes as well? Note that installing/running Brave Beta will not overwrite or interfere with any of your current Brave’s installation so this test is risk free.

Okay. I tried the beta build, I haven’t had any issues so far.

1 Like

@testuser3130,
Thanks for confirming. Keep browsing on Beta as you would normally and let me know if the crashes start again. Try and get the Beta as close to the same state as your original installation (login to the same sites, install any extensions one at a time, etc) and see if we can hit the point where the issue is reproduced.

When can I expect this beta to be released to stable?

Okay. I just updated stable version to 1.11.97 and now it crashes at the start up

@Mattches After updating to 1.11.97 I got notification about sync 2.0(before it crashes) and I was able to copy the link and read it. Then I went ahead disabled sync 1.0 (after few tries) successfully and now it’s not crashing. I think the bug is related to Sync process

1 Like

Yep, that would be it. Great sleuthing – you should be good to go now. Note that you’ll have to start the Sync process over again, as Sync v2 is a different mechanism entirely.

1 Like