Just Updated Brave Beta to Latest Build and Getting Blocked Error for Brave Official Website Along with ProtonMail

Description of the issue:

Title. Visiting Brave.com I get the following error, after updating to latest Brave beta build (Version 1.60.86 Chromium: 118.0.5993.54):
brave.com is blocked
brave.com refused to connect.
ERR_BLOCKED_BY_RESPONSE

Same response for mail.proton.me, just replace brave.com with the proton address and it’s the same exact error.

Any and all brave.com/(...) addresses
For Proton:
proton.me
mail.proton.me
account.proton.me/login

HOWEVER account.protonvpn.com DOES WORK

Did the issue present with default Shields settings? (yes/no)
YES

Does the site function as expected when Shields are turned off?
NO

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
NO, not that I am aware of.

Does the site work as expected when using Chrome?
YES

**Brave version (check About Brave): Brave Beta Version 1.60.86 Chromium: 118.0.5993.54

@Notloc can you try in private windows? And then if it still doesn’t work, try to add a new profile and test on it without changing settings or adding extensions.

Both are just to rule out a few potential issues.

Hi @Saoiray thanks for reaching out, appreciate it!

It didn’t work in a private window, does work in Tor private, and I added a new profile and it works as expected.

What might be my next steps?

Thank you for your help!

It appears some people have had this issue with other sites after previous Brave updates: https://www.reddit.com/r/brave_browser/comments/ygnw9w/getting_err_blocked_by_response_when_doing_google/

Help would be greatly appreciated, anyone??

Since it works in a new profile, it could be anything that differs from your current profile. Try disabling all the extensions and check with flags disabled.

1 Like

@Notloc it’s seeming like it might be a DNS issue or something. Have you changed anything at brave://settings/security such as Use secure DNS?

Other thing would be to suggest you go to brave://net-internals and click on DNS area. Select Clear host cache and exit Brave. Then when you return, see if it resolves or continues.

Just a FYI, this tells us that it’s likely not an extension or cookies causing issues. Which would bring us to the idea of settings you have changed or a 3rd party thing, such as a firewall or antivirus.

This confirms what I stated right above. The new profile would go by default settings. It does potentially say that it’s less likely to be something like a firewall, but you have something with DNS or connection.

@chraebsli definitely was looking at a good place. Only thing I’ll mention is that on Brave, any changes you make to brave://flags will persist across all profiles. The same is true for any custom content filters you create under brave://adblock. I strongly believe those things should be restricted to each individual profile, but it’s not set up that way for now. So it makes flags an unlikely suspect.

No settings were changed by me here. This started happening right after a beta update, with no alterations in any settings by me. Tried “Clear host cache” and exit, but it continues to happen.

No change by me regarding firewall and/or antivirus. Also, it seems to be only those 2 sites, and they both work in other browsers both on and off my network on the same device.

I did try the flags reset before I was aware that those persist across profiles.

Any other recommendations, or is this kind of a lost cause?

Also, thank you both @Saoiray and @chraebsli for taking the time to help!

I’m kind of at a limit for now. I will tag @Mattches and @steeven but with it being Friday night and near the end of the day, I’m not sure that either will see this or be able to help prior to Monday at the earliest.

I might tag in @fanboynz as he tends to pop in and out a bit more often.

Beyond that, would have to look to people not employed by Brave who might have some ideas, such as @JimB1 or @justsomeone1 .

@Saoiray I appreciate you tagging so many people to see if they can help, thanks a lot!! No rush.

I did just download the newest beta released 15 hours ago* Beta v1.60.89 (Chromium 118.0.5993.70), but the issue persists, so no fix there.

Unless its a DNS issue (be it within brave securedns or within the OS)

@fanboynz Thanks for helping! I didn’t make changes to the DNS settings within the browser or MacOS, but are there any steps I can go through to check this?

Since I’m also using Proton Services daily, I found out that these services you stated that don’t work have a link to the Tor site linked (see screenshot below).
image

And on this site, no link to Tor pops up.

I don’t know what the issue could be, but I hope others can help you with this new information.

Could it be an error in the Tor settings in Brave (brave://settings/privacy)?

Here are some Tor sites to check if this error persists on other sites with the Tor link (or if it’s just a coincidence). Also, I have some non Tor sites linked.

Tor:

non Tor:

@Notloc do you have other sites where it didn’t work?

2 Likes

Hello everyone

to make sure we removed the dns from the picture
do the following with your old profile

  1. go to brave://settings/security then disable Use secure DNS and try again maybe you need to restart your browser before trying again
  2. if 1 failed try to enable it again and try with all the predefined secured dns like nextdns / opendns and so on

and give the tor and non tor suggestion by @chraebsli a try the comment that above this one

if non of the above work

then open the old profile and new one then compare each option to make sure everything is fine or choose to reset the brave brave://settings/reset

if this did not help then most probably you have corruption on your old profile
so try to move everything from it to the new profile you created

hope that help and have a nice day :slight_smile:

1 Like

@chraebsli

@justsomeone1

None of the Tor sites above worked, and going to (brave://settings/privacy) as @chraebsli suggested, I saw under Tor windows “Private window with Tor” was turned on. Turning this off no longer redirects those sites to the Tor version. This was the fix. Thank you!!!

EDIT
Never mind, spoke too soon. This didn’t dix it.

EDIT 2
It was the “Automatically redirect .onion sites” setting. It’s actually fixed now. Must have turned itself on when the update happened.

1 Like

Also, thank you very much @Saoiray for tagging all these people and getting me help!

EDIT
Never mind, spoke too soon. This didn’t dix it.

EDIT 2
It was the “Automatically redirect .onion sites” setting. It’s actually fixed now. Must have turned itself on when the update happened.

1 Like

Awesome, glad to hear it’s resolved for you @Notloc

I’m glad to hear your problem is solved now.
Have a great day!

you welcome @Notloc

well done @chraebsli

and have a nice day everyone :slight_smile:

2 Likes