Javascript Settings Blocked By Default

Description of the issue: Javascript must be manually enabled at every website
How can this issue be reproduced?

  1. Go to a website
  2. Since Javascript, by default, is blocked, 99% of every website I go to doesn’t work &/or load properly
  3. So I must manually select to allow Javascript, then must refresh the page before I can do what I came there to do!

Expected result: The website functions and loads as it should

Brave Version( check About Brave): 1.9.72

Additional Information:

Why is it blocked by default, when even your own webpages don’t work until I unblock it? It makes every place I go unusable until I unblock and refresh, which slows down, not speeds up, my browsing, the opposite of what you advertise as one of your features.

1 Like

First, no. JavaScript is not blocked by default. If JavaScript blocked by default, then there’ll be thousands of similar posts like yours.

Make sure you don’t have script blocker enabled globally for Shield.

It’s not blocked by default? Then how do you explain this:

And I see All Scripts are also blocked, By Default, so it’s the same thing, has the same effect, if all scripts are blocked by default, that would include javascript:

Hi, @StevenCee. However the setting got enabled, it looks like you found your way to what needs to be changed - the Global Shields settings. If you click the slider for the Block scripts option to toggle that setting off, does it work or does it refuse to be disabled?

To help flesh out the situation, could you provide your version of macOS? It should be included in the brave://version information page if that’s convenient.

And both you and @eljuno are right: it’s not supposed to be on by default, so if that’s the way it installed, that’s weird. I just downloaded and launched, but forgot I had preferences from an earlier install (I use Brave Nightly as you can see in the image). When I reset to defaults, Block scripts was off, same for creating a new profile, but that doesn’t mean yours didn’t install that way somehow. however weird or unlikely.

Yes @StevenCee. JavaScript is never blocked by default. And that’s a default settings for all users. Because Brave team also knew that by blocking JS by default, it’ll break most sites and the numbers of (similar) reports will be higher.


By default, Brave lets sites run JavaScript. Many websites require the use of JavaScript in order to display properly or access some functionality of the site.

It seems that you already use Brave for months. So it’s just weird that you just encounter this issue recently. Because if it’s blocked by default, you should see the issue months ago.

But flipping the switch for “Script blocker” should fix your issue.

If you sure you never enable the setting in first place, then it’s another question mark.

Yes, it is very odd that it just began, although it may have just started after doing an update to the app. I hadn’t used Brave for awhile, and then when I did, there was an update to it, so that may have somehow flipped the switch. But still, that doesn’t explain why you can’t simply enable Javascript, and not all scripts, which would be my preference. So the question still remains, why can I not unblock Javascript, the very same way I can do with the others. For if it’s not the default, then that means there has to be a way to block it, but then there’s no way to unblock it, without unblocking all scripts? Makes no logical sense to me…

So if you say it’s not blocked by default, what would you have to do to block it? And if it’s not blocked already, that means it’s possible to keep all other scripts blocked, while not blocking Javascript, yet once it’s blocked, you have no other options?

Good morning, @StevenCee. I’m a bit confused. Are you able to turn off blocking of scripts with the toggle? I’ve seen bugs where some toggles refuse to be switched, which is why I ask.

@eljuno has already weighed in and is an authority, but I’m fairly certain “scripts” in this context is referring to javascript only, and I’m not sure what other scripts might be involved: Python or php, maybe? But my understanding is that Python, php, and asp are server-side scripts that don’t run on the browsing machine?

Bottom line: that toggle for scripts should be the one you want, unless it does block more than javascripts and you want to pick which varieties are blocked.

Hi, I’m just saying that yes, you can block “all scripts” using the toggle switch, but that the preference specifically having to do with Javascript has a toggle switch permanently in the Blocked position. So, if you want to enable Javascript, the only way is to unblock ALL scripts, which defeats the whole purpose of having the two options (since one is not an option). So if I want to enable Javascript, but not any other scripts, I can’t.

I am having the same issue.

There are actually ways to block Scripts in a more granular way (we are working on improving this feature presently). But at this time:

  1. On the site, select Block scripts
  2. Click the arrow next to the setting to reveal individual scripts
  3. Select individual scripts to allow:

@eljuno [quote=“hnktong, post:8, topic:129930”]
Good morning, @StevenCee. I’m a bit confused. Are you able to turn off blocking of scripts with the toggle? I’ve seen bugs where some toggles refuse to be switched, which is why I ask.

It is possible to unknowingly change an individual setting in Settings with an inadvertent mouse click that is near but not necessarily on an individual toggle when navigating on the page. I have done it a number of times. This is not a bug AFAIK.

That is NOT a solution… If I have the Block Scripts option enabled, it will also block Javascript, which is the original issue! Every site i go to, including Brave’s own website, won’t function properly until I disable the Javascript block, then refresh the page, which is a big time waster, and totally unnecessary, especially from a browser that touts being a time-saver. What you are suggesting, adds even more busywork, and is also out of my expertise, because how do I know which of the 12 scripts I want blocked, or unblocked?

All I’m asking is why can’t we universally NOT BLOCK Javascript? Why is the default “blocked”, with no ability to toggle it so it won’t block it on every site, so I can just open websites as I have for the past 30 years?

Yes I can block ALL scripts, but I don’t want Javascript blocked, and there no way to toggle the block Javascript to unblock, unless I do it at every site I go to…

Toggle Scripts to “Off”

What scripts besides JavaScripts are there to block?

I don’t know the names of other scripts, but I know some scripts are not good to be run. But again, if disabling “Block Scripts” is the only way Javascript will run, then why have a separate option to block Javascript, especially when that toggle can’t be turned off?

And any idea why my top sites suddenly went from about 10, down to 3? Where did all my others go? I thought I had them all pinned, but they still disappeared, any ideas as to why this happened?

I am 99.9% certain that “Scripts” is just short for “JavaScripts” in Brave’s settings.

I tested this by leaving a window open to the JavaScript domain name black- and whitelist page, then going to a site, clicking the shield icon, and clicking the “Block scripts” toggle. The domain name was added to the blacklist, and then again toggling the setting from the shield icon menu moved it to the whitelist.

I posit that the devs just shortened the word in the Shields settings (brave://settings/shields for Global, clicking shield icon for site-specific) while not in the “Sites and Shields settings” where the white- and blacklists by domain name are.

I understand why one might get the idea that there are other scripts involved since your question caused me to doubt my initial conclusion, but unless @eljuno, @Mattches, or another Brave person says otherwise, the two terms are synonymous at least in Brave settings context.

Does this help, @StevenCee?

I’m not entirely sure what you’re trying to achieve here – perhaps further clarification is needed?

First – does work with Scripts off – not ever single feature of the site works mind you but 90% of it does, which is quite impressive all things considered.

According to :

This makes it seem like you want to have Javascript “scripts” blocked across all websites. If that’s the case, change the Scripts control setting in Settings --> Shields, as this will set the default settings for Shields on every website.

If you want to keep scripts blocked in this way – that is, if you want to block javascript from running, most pages will be broken, as you’ve described since the web runs largely on javascript for rich, dynamic content. However, you can open the Shields panel on any page and toggle the Scripts option “on” for any site you want scripts to run on and it will function as intended.

And finally, part of the confusion here may be the fact that when you block (or allow) scripts, 98% of the time, you’re referring to Javascript specifically. To be clear:
Scripts/Scripting: Scripting is a specific type of programming that (generally) adds dynamic or automated content to a [website].

Javascript is the most popular type of script that you will encounter – can you tell me what other scripts you’re concerned with blocking? Other popular scripts may include PHP or Python – but its worth noting that those are also blocked by the scripts toggle as well.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.