JavaScript on macOS disabled by default

Description of the issue:

I freshly installed Brave Browser (version 1.23.73) on macOS Big Sur (version 11.2.3) for the first time ever, added it to my sync chain consisted of a Brave Browser installations on a Linux and on an Android, and JavaScript was blocked by default for all sites. I.e., “Block scripts” was turned on in the Shield settings. I did not experience this issue when I installed the Brave Browser on Linux (Brave Browser version 1.23.73) and Android (Brave Browser version 1.22.71), and I never turned on blocking scripts.

How can this issue be reproduced?

  1. Install Brave Browser (version 1.23.73) on macOS Big Sur (version 11.2.3).
  2. Add it to a sync chain consisted of a Linux and Android installation. (This step is probably unnecessary, but I am mentioning it here because that’s what I did.)
  3. “Block scripts” settings in on.

Expected result:

  1. “Block scripts” settings should be off.

Brave Version( check About Brave):

1.23.73

Additional Information:

This issues seems similar to Javascript Settings Blocked By Default - #4 by StevenCee

Go to brave://settings/shields and then scroll to “Block scripts” (in the middle of the list). Deselect it.

Thanks @plasmi, I know how to fix it. My point is that “Block scripts” should not be enabled by default, because it renders the browser pretty much usless and might make users who are not computer literate uninstall it immediatlly after they try it out on a few web pages.

“Block scripts” remains to be a great option for advanced users, who can easily enable it by themselves, if they want it.

I had my block scripts automatically disabled; maybe you installed it at an earlier time and it did that?

No, this was the first time I ever installed the Brave Browser on MacOS.