Infinity load in random pages ( ⇦ Slow loading or No loading)

Addendum to my earlier reply

A Mac OS Terminal.app command, for starting Brave Browser, including the switch of interest:

  • --enable-features=NavigationThreadingOptimizations

. . . is within the following shell script.

Purpose of this script, is to make the startup task easier.

After downloading this script to your Mac Desktop, change the .txt filename suffix to .sh (script name needs to be ‘BB_Mac_start.sh’)

Instructions are also in the script, and you may view and edit the script as you believe necessary.

BB_Mac_start.txt (2.0 KB)

same issue here in linux.
getting to be a real pain

Anyone still having issues, try enabling brave://flags/#enable-prerender2.

1 Like

@fanboynz This seems to be fixing this issue for me! Thank you! :slight_smile:

Upgraded to 1.40.105 and so far problem has been solved. Hopefully it will last.
Thanks.

Have seen th same on mine since the upgrade. Seems to be working fine now.

3 Likes

I would like to also report that after the latest upgrade the problem seems to have been fixed.

2 Likes

Working now for me as well. Thank you!

1 Like

Still not working after new fresh update I saw few people wrote here that we need something to do through cmd to enable something ?

It depends on the issue. The major, widespread one that I’m aware of should ‘fix itself’ upon the browser fetching a new config from upstream – in other words the problem should go away, provided that you’ve relaunched the browser recently (I’m guessing you probably have, considering you’ve updated it).

Then there was also this that you could try: brave://flags/#enable-prerender2

Additional information from the the Brave GitHub issue report:
Many users experiencing extremely slow load times (or no loading at all)

atuchin-m commented

The issue was fixed by updating a feature config that is fetched by the browser from time to time.
Any release should works fine now.

Exception Instructions

atuchin-m commented

Guys, we recently have rolled out the feature to all audiences.
We believe you shouldn’t have this issue anymore.

If it seems you still have it, please restart the browser (to update the feature config) and check the symptoms.
The original issue had a few characteristic symptoms:

  • Absolutely blank page, no any visible content;
  • True infinite waiting loop, not a delay (nothing is changed after minutes/hours);
  • Reloading the page usually helps;
  • Disabling Shield/DeAmp doesn’t change anything;

If the symptoms don’t look like this, please file another issue.

If you are absolutely sure that you have this issue please post here: