Infinity load in random pages ( ⇦ Slow loading or No loading)

Deleting cookies and cache doesn’t solve the issue.
If solve in your installation, maybe wasn’t related with this case


Seems like the cookies suggestion has resolved the issue for some but not others, and also the recent updates (btw latest hotfix update is for v1.39.122 — please update and test again to see if the issue is resolved afterwards) resolve the issue for some but not others.

I’m bringing this information to the team again and will see what they say. Again, please ensure everyone updates to the lates build (v1.39.122).

1 Like

No change with 1.39.122 for me, cookie fix doesn’t work either.

M1 Macbook Air, MacOS 12.4


I tried changing my search engine from Google to DDG and while not ideal, it seems to have helped.

1 Like

Version 1.39.122 Chromium: 102.0.5005.115
Still nothing - new profile no loading only few sites also tried with private window same outcome.

1 Like

updated…reinstalled cleanly…browser history, cookies, cached images and site setting all cleared on close of browser. eetcvetcv etcv etc…

All this crap should not have to be done to simply use a browser.

We do not need to go through that with Chromium, Firefox etc etc

This issue started ion MAY 29

1 Like

Same here. But why are you guys uninstalling and reinstalling your whole computers? Geezuz. There are plenty of people that have issues and they have done no changes. This is a problem at Brave.

Have issues both at desktop and mobile.

I don’t think there are users reinstalling the system. :slight_smile:

But the problems appear to be only related with the desktop version - in multiple systems, Windows, Linux and macOS.
Android and iOS doesn’t appear to be affected.

Yeap for me on phone everything is working fine but on PC I have problem for long time 2/3 weeks.


looks like they finally found the issue and are implementing fixes in nightly. really hope it’s fixed for good soon, because it’s really intrusive


Temporary fix (thanks to investigations by Brave developers plus others at GitHub), until updated stable release of Brave Browser comes along . . .

Windows OS users:

At , a recent comment by ‘Gorxor’:

Added --enable-features=NavigationThreadingOptimizations to my desktop shortcut (Windows 10), and no more “sometimes page doesn’t load on first try” issues anymore for me as well. Also no crashes or other problems detected yet.

Mac OS users:

You would start up Brave Browser using the command line.

At , a recent comment by ‘nintendodork07’:

in terminal put:

open -a "Brave" -n --args --enable-features=NavigationThreadingOptimizations

What I finally did, in order to make use of the proposed fix, switch:

  • --enable-features=NavigationThreadingOptimizations

In a Brave Browser > New Window, I sent the browser to: brave://version

I copied the entire Command Line string, to a text editor window, in which I could then edit the string.


The leading part of the Command Line string:

  • /Applications/Brave Browser

I replaced with the following string:

  • open -a "Brave" -n --args

then I added a single SPACE character, followed by all of the known switches (there are several) plus any flag switches.

IF there are flag switches, then they will begin with switch:

  • --flag-switches-begin

and end with switch:

  • --flag-switches-end

So, IF there are flag switches, then the proposed fix, switch:

  • --enable-features=NavigationThreadingOptimizations

I located BEFORE switch:

  • --flag-switches-begin

IF there are NO flag switches, then I located the proposed fix, switch at the tail end of all the switches.

And I made sure to also include the necessary single SPACE characters, because there needs to be a single SPACE character that separates all the switches.

I am using 2 flag switches.

So, the altered Command Line string that I use, became:

  • open -a "Brave" -n --args --disable-client-side-phishing-detection [FOLLOWED BY MANY SWITCHES, AND THEN THE PROPOSED FIX, SWITCH:] --enable-features=NavigationThreadingOptimizations --flag-switches-begin [FLAG SWITCHES] --flag-switches-end

That is the Command Line string that I entered into the Mac’s window, in order to start up Brave Browser.

@Chocoholic tip - tx

1 Like

This does not work for me on MacOS. Launching this way thru terminal command still requires 9 seconds before i only then see the cached page of the last URL i’d opened, but then it takes another 60+ seconds of idle time whereby I cannot click new-tab icon, I cannot perform any actions at all in the browser, i just have to wait and wait and wait until whatever is happening in the b.g. unbeknownst to me completes. There’s no visual or other indicator that “ok, you can now use the browser and it will work”. It’s all trial and error.

My intent is to go back and back to prior stable releases at github to trial and error if any of the prior releases are problem free. I understand @djprmf djprmf( 's warning that prior releases wont have the latest security patches, and that’s incredibly impt. But right now I just want to see if there is a relatively recent release that “works” without these long inexplicable background loading processes that render the browser unusable.

So, for example, here is a stable release from about a month ago (May 2022), but i cant figure out how to download a MAC .dmg or .pkg installation file. Github’s generic instructions do not make any sense to me; I am not an engineer.



Brave-Browser-*.dmg or Brave-Browser-*.pkg will install this version.

what does this mean? How do i formulate a URL that will download me the Mac version? I take it * = the version number … but please if anyone can help me, much appreciated. Just seems to me if we “crowdsource” this via trial and error, a BRAVE software engineer can then trivially recognize what new/different element in the more current source code is the likely instigator of the problems so many people are seeing ?

1 Like


Thanks for trying. I amended my previous reply, again.

My suggestion, is that you wait for the next Brave Browser update.

1 Like

Just FYI: This problem still persists and reinstallation solves it only for a day or so before it returns. So it definitely seems to happen after something changes in the browser.

1 Like

We all from here are waiting for new fresh update so we can continue using brave like before.

1 Like

I know I can go on github, but I shouldn’t have to. I’ve been on Brave since the beginning and I’m starting to lose patience.Why can’t this be solved quickly? So any news on how long for a solution?

1 Like

Yeah, it’s a little annoying. I expected today’s update to fix the issue but it didn’t.


Same issue persists here after 1.40 update today … I am on Desktop Linux via Chromebook.

1 Like

Probably the best way to monitor the situation would be to watch for the GitHub issue(s) to be closed out.

I notice someone submitted a PR also which he seems to think will fix it, but I have no idea whether there’s any validity behind this.

1 Like