How do I turn off Brave from being my default browser

I am a decades long user of Firefox. I added Brave because I had one recurring problem with Firefox since two updates ago, which no one seemed to be able to explain. It’s not that I don’t like Brave, but I’m really much more comfortable with Firefox. I changed the default browser to Brave in a moment of frustration. I finally did a sensible thing and removed firefox completely. And installed a fresh copy of the latest version of firefox. The problem that had plagued me for a while is gone. I went to switchthe default again and there is nowhere in settings that I can detach the default from Brave. I would appreciate some help with this.

I thought of doing the same with Brave (remove and load a new copy) but this is on a linux machine and Brave in not in the app where I install my software. I’m a relatively new user to Linux and this has me stumped.

You can set it from Fx settings.

https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser#firefox:linux:fx90

Unfortunately, there is a note in red on my settings page in Firefox that says "your corporate entity is controlling your default setting. It seems that I downloaded a business version of Firefox - so I can’t do it in Bravo or Firefox. There is no enterprise controlling my personal computer as far as I know. I guess I’ll contact Firefox to see what to do. Thanks for replying :upside_down_face:

Thank you for your solution. I went to the Firefox community and got my answer and partially solved the issue. Firefox enterprise edition is controlled by a “policies.json” file. Because Firefox respects the primary interest of a business to set the standards for use of software, the policies.json file is set to defer to corporate control. Having set Brave as default browser, it locked up Firefox options.

I followed the directions for editing the json file. Rebooted my computer and, sure enough, the “Make Firefox your default browser” popped up after the reboot.
I went to Brave settings and still found that it held that “Brave is your default browser.” The phrase was locked with no way to change it.

So, when I started up the computer this morning and opened Firefox and up popped the box “Make Firefox your default browser”. I clicked on it again. Then, I went to Brave settings - and nothing had changed.

What I need now, somehow, is to reset Brave. Otherwise, I’m going to spend the rest of my days clicking “yes” to Firefox’s "Make Firefox your default browser.