Turn off the “Brave is not your default browser…set as default” popup

Description of the issue: Every time I start Brave, I get the alert “Brave is not your default browser … set as default”, and I have to close the alert every time, instead of being able to use the browser directly. And I don’t want Brave to be my default browser, but it’s really really annoying to have to close that alert every time.
How is it deactivated?

Steps to Reproduce (add as many as necessary): Open browser.

Expected result: Turn off the alert

Reproduces how often: Everry time

Operating System and Brave Version: Windows 10 and Brave Versión 1.21.73 Chromium: 89.0.4389.72 (Build oficial) (64 bits)

5 Likes

Can confirm. Happens also on Version 1.21.73 Chromium: 89.0.4389.72 on Ubuntu 20.04
Very Annoying. Please fix this!

2 Likes

I use Brave solely for email and not as a default browser. I would also ask, “How do I turn off the nag screen asking to be default browser?”

If it continues I will simply uninstall Brave

very disrespectful.

2 Likes

Hello @MikeSto @daffyd @asfdfadsafsr

after around 3-4 times it stop asking you that at least that what happened with me

hope that help you with that and have a nice day :slight_smile:

Add me to the list of affected, happening here also. Started around the 3rd I think.

Can confirm this issue. I use Brave as the default browser on my Laptop, but I use something else on my PC. Will uninstall on all platforms if this is not fixed.

1 Like

@Browserspace @MikeSto @daffyd @asfdfadsafsr

vote for this one How do I stop Brave asking to be my default browser?

so the team notice that and implement something for that

3 Likes

Same problem here, At my homepc i use brave as the primary browser. But the work PC has it as the secondary browser. There its very irritating that every day you will be deminished in productivity because you have to activily push a button that’s not needed (dev wise its the worst kind of bug there is, anti automation).

I’m having the same issue. This is getting really annoying. Please stop it!

I voted but for some reason this issue only has 4 vote. Please vote people!

Please add me to the list of disaffected users. This started this week.

I have six browsers installed and Brave is the only one currently rearing it’s head in this needy way.

1 Like

hello everyone @OrangeHedgehog @Rafael_Kinder @moshner @pomp0m @Browserspace @MikeSto

the team is going to fix it

check this one

have a nice day everyone

1 Like

This is a great way to drive away longtime and potential users. Hopefully this will be resolved shortly.

This is incredibly annoying as it prevents any other activity on that window until the notification is cleared.

Don’t dictate to us; fix this functionaity (e.g. “Don’t ask again” option), or be uninstalled.

Hello @Antonimo

it fixed now for the last brave version


Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (64-bit)

so check make sure you have the latest version

hope that help and have a nice day :slight_smile:

1 Like

That’s great. Only four days after this thread was started - that is a very good response time.

Thank you!

you very welcome @Antonimo

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.