How can I delete a persistent cookie in my "Sites that can never use cookies" list?

After I clear “Cookies and other site data” one cookie remains called “ Service Workers”.

When I try to delete this cookie by itself, it still returns. I use the “block third-party cookies” setting.

So I added the website name to “Sites that can never use cookies” but this made no difference. I added it in 2 forms: and Neither work. I rebooted my laptop and nothing changed.

I think the original source was an online radio station that I deleted using a Brave window dedicated to listening to the station. There was no other way to close it that I could find.

I expected all cookies to be deleted. I’ve done this many times and get that result.

It reproduces always today. Never had this issue before. I searched for listennotes in my home directory but it was not there.

Linux Operating System and Brave Version(1.43.93 Chromium)

Try going to the site in question and putting shields up. For some reason, Brave will not allow you to delete cookies for sites that have shields down.

I have shields up by default, but I updated all the other settings on the Shields page to the most aggressive including block scripts and checked every Content Filter. The cookie keeps reappearing though.

I was surprised this changed my filter settings for every website. But as expected it did not apply the other settings changes I made on the main Shield window to other websites.

Shields works on a “by site” model (as well as the global settings), which means that it remembers your shields setting for each site. This will override the global settings. Most aggressive should only be used for sites you think are dangerous as most web pages won’t work right on that setting. The default setting is fine in most cases. You can add lists to shields for more pointed protections.

You need to go to the particular site whose cookie you want to get rid of and there turn shields on. You may have turned it off because the site didn’t work or something. Turning shields on or off on another site will only affect interactions with that particular site. GLobal shield settings are overriden by local settings.

Thank you, I should have been more clear. Shields have always been up and are currently up for the site in question and all websites I open. It is my default setting to have Shields up.

I did go the the site in question to check out its Shields and updated the Shield window with the strictest of protections as listed in my reply. However the " Service Workers” cannot be really deleted. I clear all cookies it and it appears again by itself if I refresh Cookies setting page, while all other cookies are deleted.

Is there another way to get rid of this cookie?

Ok, do you see the cookie on this page in settings?


If so, what happens when you click the little trash can to the right of the listed cookie?

If the service worker is stuck, enter:


in the address bar of your browser and unregister the worker. Then return to


and click the little trashcan next to the cookie (if it is still there).

Tossing this your way to see if it might help @Heidi2

I know you tried at least some. In the meanwhile, I’m going to loop @Mattches into this because I know this issue keeps coming up.

It occurred in August but eventually closed with no updates, over at "sites which are always allowed to use cookies", trashing does not work - #14 by MrPassey

Had a more recent at Undeletable cookies

And I know they had some dating back to like 2020 where a GitHub was linked. Someone posted last month that the issue still hasn’t resolved.

I went through all of your instructions, however the cookie of concern still reappears. Below I pasted the line from the serviceworker-internals website:

Registration ID: 386
Navigation preload enabled: false
Navigation preload header length: 4
Active worker:
Installation Status: ACTIVATED
Running Status: STOPPED
Fetch handler existence: EXISTS
Version ID: 401
Renderer process ID: 0
Renderer thread ID: -1
DevTools agent route ID: -2

I plan to uninstall and then reinstall the Brave browser to see if that gets rid of it.

Thanks so much. It’s interesting that I do not have any cookies in “sites that can always use cookies” as some previous users did and yet the cookie of concern keeps reappearing.

I will look over the threads you listed.

1 Like

It would probably be easier for you to simply create a new profile. Profiles are supposed to be completely separated from each other. Menu > create new profile, or simply click your profile icon. Then later you can delete your previous profile, or keep it if you want.

1 Like

@bravoguy that wouldn’t necessarily solve the situation. Also, creating a new Profile creates a new Rewards. May not be that big a deal if they are Verified but still a bit annoying.

@Heidi2 That said, where you mention uninstalling, that will erase your Rewards as well. So anything not over at Uphold/Gemini will be lost if you do that. So in that situation, it would be better to do as bravoguy mentioned.

I created a new profile and visted ( I checked my cookies and a google and another website listed below appeared under “Sites that can always use cookies”. I was able to delete them and after refreshing the page they appeared under " Sites that can never use cookies".


Well, Brave took care of those unwanted cookies handily! I added another website and no unusual cookies appeared. I’m very happy with this result and will be transferring my passwords and bookmarks over to the new profile.

1 Like

Just makes you wonder what setting, extension, or whatever else caused the problem with your original profile. Can’t say it’s a solution but at least a good workaround for you.

1 Like

Thanks for letting me know that I may be giving up Rewards, but I’d rather do that than have a weird cookie permanently fixed to my account. I actually just switched to a new laptop and thought I could add the rewards from my previous one at some point, but I guess not. That’s okay with me.

Well, you can. If unverified you would have had to do a backup of your /brave-browser folder and move it over. Then you would have been set. If you install fresh version and then open browser, it creates a new Rewards ID…so you’d have to move it over before that.

If Verified, then all your BAT payouts would be stored at Uphold/Gemini and just Verifying on new device would have those visible and seen.

1 Like

As far as what caused the problem in the first place, i think it was likely along the lines of the third known cause that CerealLover listed in one of the threads you posted here for me to consider:

  1. You enabled ‘Allow Google login buttons on third party sites’ especially for the urls: https://[*.] and

I think this because these same two websites popped up in the new profile I created.

I wonder if I inadvertently selected this on a pop-up that I might not a have read thoroughly in trying to get to my next task. I’m often a bit inpatient when I get one of those pop-ups asking if the site can have my location data. I just changed the Brave setting to not to be asked. Maybe this will help avoid the unwanted cookie problem in the future.

@Jarc-1107 did you accidentally hit the wrong thing? You converted this topic to a private message, which is preventing other Users from seeing any info. I’m wanting to guess you might have meant to lock it?

I didn’t intend to convert the topic to a private message or lock it. I didn’t even know these options existed. I’m not sure how to undo these things.

It wasn’t you Heidi. It was person I linked to. I don’t know who they are yet, but @Jarc-1107 is a moderator who just joined yesterday.

Untitled - Brave 9_21_2022 8_59_13 PM

Whether is brand new employee with Brave, employee who just set up new account but been with Brave a while, or what? All we know is Moderator level is usually Brave paid staff only.

I’m assuming they meant to lock this topic/thread since everything was resolved, but likely hit a button to convert it to a private message instead. I tagged so if they do come on tomorrow, might be able to reverse it. I’ll also add in @SaltyBanana in case.