High Memory/CPU usage

I was looking at this topic (since I’m facing the same issue) and talked to Bitwarden, to which they replied:

“I currently have the Brave browser open on Windows 10 with Bitwarden installed and logged into and 3 tabs open. Monitoring the task manager in Windows shows Brave using 0% CPU, or 1-2% while switching around to different tabs in the browser.”
As for myself, 73% with (27) right beside Brave Browser on Task Manager (3 tabs open)… anyone know how to help?

Version 0.56.12 Chromium: 70.0.3538.77 (Official Build) (64-bit)

Happy to help!
First, can you go ahead and update to v0.56.14? Just want to make sure we’re working with most up to date code.

Hi Mattches! Sure, just updated. Issue seems to remain.
Thanks!

Still facing this issue, which kinda sucks, it really is slowing down my PC a lot… I want to keep using Brave, but I find myself closing it and going back to Chrome more frequently than I’d like =/

Try uninstalling Bitwarden and monitoring the changes.
Let me know what you find.

I hope I’m not hijacking onto the thread but I’ve been experiencing the high CPU usage issue as well.

It seems to be related to open tabs. I typically have about 4 - 5 open tabs - two for email (Gmail), as well as other sites. But the problem really gets bad when I’m on FB and I open notifications in tabs as well.

Each tab takes some chunk of CPU time. If I bring up Activity Monitor, I can watch the CPU usage for Brave Helper ramp up from say 3 % to 85% to 110% to 123% or more of CPU time. I’ve found killing off that Brave Helper process (a Force Quit is never required) helps. The page in question gives a black background and frowny face, but if I then refresh the page (Command-R), the FB page redisplays almost as if nothing ever happened.

It’s a work-around…not a happy one but it works. But is there any fix in sight?

I’m running:
Brave 0.25.2
V8 6.9.427.23
rev 8ea2a9c
Muon 8.1.8
OS Release 14.5.0
Update Channel Release
OS Architecture x64
OS Platform macOS
Node.js 7.9.0
Brave Syncv 1.4.2
libchromiumcontent 69.0.3497.100

@Cakewalk,
I’m not sure if you’re aware, but we’ve recently depreciated the Muon build of Brave (the one you’re using, v0.25.2) in favor of our new Brave Core build:


https://brave.com/download

I highly recommend you install the new build and enjoy a much better browsing experience.
It runs in parallel with the Muon version you have installed now, so you don’t have to uninstall or overwrite anything and you can even import data from your previous Brave install into the new build.

If you decide you’d like to stick with the version you’re using now and want to resolve the problem or troubleshoot, let me know and I’d be happy to assist.

Thanks… I wasn’t. Um… silly question… when I click Brave, “Check for Updates” I get a message, “Not yet! Sorry, there are no updates yet. Please check back soon.”

When I tried the download link - both what you provided and by going to brave.com myself, nothing downloads.

Can you tell me how I can get the new build?

:point_up_2: This is because we aren’t yet offering a direct upgrade to Brave Core from Muon. That update will be coming shortly.

I image you got routed to the “Thank you” page after clicking download? If so, simply return to the download page, refresh, and try again. This website issue popped up recently - I was actually dealing with it earlier myself. Let me know if this doesn’t resolve the issue.

Ah… that makes sense…

You are quite correct. I’ve tried to reload the page several times now and I keep getting the same thing. I was however, able to download it via Firefox (my former preferred browser). I assume installing it from that download should be the same…

It will be, but that is certainly very strange. I’ll have to have someone look further into that. Appreciate your patience. I’m going to go ahead and close this topic now. If you have any further questions or concerns please feel free to open a new topic and we’d be happy to assist you.