[Help] How to turn off Brave Browser Auto Startup?

Description of the issue:
How can this issue be reproduced?

  1. When I turned on my MacBook, Brave Browser would always “auto start.” Even after I turned it off using “Login Items” from “User and Group,” it remained and continues to turn on after that.

Furthermore, I tried installing “CleanMyMac” and turning it off, but it still turns on whenever I start my MacBook, which is getting aggravating because it appears that there is no single approach that works best.

Expected result:
When I turn on my MacBook, I expected “Brave Browser” to remain turned off.

Brave Version( check About Brave):
Version 1.41.100 Chromium: 103.0.5060.134 (Official Build) (x86_64)

2 Likes

@Aircon it’s kind of running in the background as that’s what it needs to do for Brave Rewards if you’ve opted in.

That said, you can try to go to brave://settings/system and make sure you have turned off the option for Continue running background apps when Brave is closed

Do advise is the setting makes a difference. If not, try turning off Brave Private Ads and see if it changes anything.

Just are two basic thoughts I had for a moment. Assuming primary is the “run in background” setting.

@Aircon

If you have Brave Browser set to be the default Internet browser . . . choose some other Internet browser (Safari will do, for now).

Some Extensions may cause a problem, and you may need to:

  • Disable all Extensions
  • Remove all Extensions
  • Test Enable each Extension, alone, one-at-a-time in order to detect the influence of that Extension
  • Determine which Extensions are running in the background

Mission Control might have become an issue:

https://support.apple.com/en-us/HT204100

Borrowing from what @hnktong wrote in 2020 . . .

the places I know that house startup items are:

  • In System Preferences, Users & Groups, Login Items for your account
  • In your home folder/Library/LaunchAgents
  • In /System/Library/StartupItems
  • In /Library/StartupItems

And borrowing again from what @hnktong wrote in 2020 . . .

Something that at least used to trigger opening Brave (and Chrome) is if Hangouts is turned on (click to enlarge):

https://global.discourse-cdn.com/brave/optimized/3X/8/3/83e2495dee801d4e8edd1656c15db4827b18f11c_2_345x109.png

In a Brave Browser > New Window, go to: brave://settings/getStarted

  • Select: Open a specific page or set of pages
  • Select: Add a new page
  • Enter: about:blank (notice the colon)

In other words, you are DISABLING: Continue where you left off

Next, go to: brave://settings/clearBrowserData

For tab Advanced

  • Set: Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: `Cached images and files``

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

Next, go to: brave://settings/clearBrowserData

For tab On exit

  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files
  • Enable: Hosted app data

Click on the ‘Save’ button.

Reduce influence by websites:

In a Brave Browser - New Window, go to: brave://settings/content

Scroll down to Additional permissions . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to Content . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

RESTART YOUR COMPUTER and proceed to Safe Mode:

Starting up your Mac in safe mode can help you identify whether issues you’re experiencing are caused by software that loads as your Mac starts up.

  • Remove Brave Browser from list of Users > Login Items
  • Set Safari to be default Internet browser

RESTART YOUR COMPUTER and proceed to Safe Mode

  • Run Brave Browser
  • Exit / Quit Brave Browser

Does Brave Browser then show again in list of Users> Login Items?

While NOT running Brave Browser, locate the ‘Caches’ folder: /Users/username/Library/Caches/

Therein:

  • locate the ‘com.brave.Browser’ folder and move the ‘com.brave.Browser’ folder to the Trash
  • locate the ‘BraveSoftware’ folder and move the ‘BraveSoftware’ folder to the Trash

Restart your Mac

Brave Sync might be a problem. You may have to Enable / Disable Brave Sync when needed, instead of leaving Brave Sync enabled.

For now, Disable Brave Sync, for testing your issue.

Worth a look:

https://www.hexnode.com/forums/topic/unable-to-change-user-account-password-on-mac/

EXCERPT:

The Screen Time settings will be shared across all your Apple devices if you’ve signed in using the same Apple ID, and ‘Share Across Devices’ is enabled on any device signed in to iCloud.

Quick Fix

Exit / Quit Brave Browser.

Use System Preferences > Users & Groups > Login Items . . . and REMOVE any Brave Browser items that would open automatically when you log in.

Quit System Preferences -AND- wait 1 minute.

Locate the ‘com.apple.loginitems.plist’ file:

  • /Users/username/Library/Preferences/com.apple.loginitems.plist

Select that ‘com.apple.loginitems.plist’ file and choose the ‘Get Info’ selection under the ‘File’ menu of the Mac OS ‘Finder’ menu bar.

Find in the Get Info window, the ‘Locked’ checkbox and Enable that checkbox. Close the Get Info window.

Exit / Quit applications and Log In. Did Brave Browser launch after the Log In? (Yes after Log In / No after Log In)

Exit / Quit applications and Restart your Mac. Did Brave Browser launch after the Restart? (Yes after Restart / No after Restart)

Login Items

https://www.makeuseof.com/tag/add-remove-delay-startup-items-mac/

https://jogendra.dev/implementing-launch-at-login-feature-in-macos-apps

Advanced Mac OS tools

https://www.bresink.com/osx/TinkerToolSys7.html

You can really mess up here, when not careful and precise.

launchctl

https://rakhesh.com/mac/macos-launchctl-commands/

https://support.apple.com/guide/terminal/script-management-with-launchd-apdc6c1077b-5d5d-4d35-9c19-60f2397b2369/mac

https://www.real-world-systems.com/docs/launchctl.1.html

You can really mess up here, when not careful and precise.

defaults write

https://wilsonmar.github.io/dotfiles/

https://github.com/mathiasbynens/dotfiles/blob/main/.macos

That option is not available in macOS versions of Brave, at least not mine. I have the same issue as @Aircon and I have my own thread (and 4+ other people do too) with no fixes to this issue.

Well, darn. This is the bad part about not having the OS as someone else who is having issues. I’ve no idea on MacOS or Linux but try where I can. Usually they keep things almost identical on Desktop feature though. Mind doing a screenshot of what you can see at brave://settings/system so I can see options they do have? Just out of my own curiosity to see what it does have listed.

@CerealLover you’re usually good with things like this. Do you have any ideas?

It’s easy to miss some issues and also easy to forget. Just like I guarantee I have topics/posts that I’ve stopped responding to. But to go through ALL my notifications and replies to try to figure out, it’s tough. It’s why I stress to people it’s kind of important to quote or @ people when talking, at least is like that for me. If no response for a period of time, tag or DM to draw attention to it again. It’s not that people get ignored, but you’d be shocked how many things cry for attention.

It’s even worse for Brave staff who have to handle all of that here AND do stuff on Github AND answer tickets AND work on things for development AND answer DMs, etc. Definitely plenty of things to keep the occupied on a regular.

That said, I’ll throw out a tag to @Mattches and see if he might be able to swing by here at least for some ideas once he gets settled in.

Sure, here’s a screenshot for ya: https://imgur.com/AhYHZWJ
(For some reason I can’t upload to this forum…)

Should be able to I think. You’re Basic on Trust Level, which allows to upload image. Btw, you can see what you can and can’t do on Trust Level here and how to get the next level at https://blog.discourse.org/2018/06/understanding-discourse-trust-levels/

Yeah, ok, so same just with that one missing. I’ll have to find out from them later what the difference might be.

Hi

Have you tried the steps @ https://www.youtube.com/watch?v=szYIiOZizCg

This is what I have to do every single time I turn my Mac off and back on. Brave keeps auto-adding itself to that Login Items place

I would love if a Dev would chime in and let me know if there’s a flag I could turn off. I doubt it but worth a shot. I know for a fact any developer using macOS has encountered this issue.

From what I gather, this has been an issue in the Chrome/Chromium browsers for nearly a decade, but I believe Chrome actually fixed it. Brave, not so much. No idea why, but it is infuriating to have Brave auto-start every time with no way to turn it off.

1 Like

Hi

It is safe to reset flags, supposing you haven’t enabled/disabled features before.

Yeah I haven’t messed with flags and none are changed so that won’t make any difference for me at least.
My hope is that maybe a dev knows a flag to change to fix this, but I really don’t think one exists unfortunately.

Is it a bug, is the problem with Brave!
I leave a tag @WildVirus who had a similar issue a few months ago.

1 Like

Hello there This approach hasn’t worked for me after trying it. It seems like the “Brave Browser” will continue to show up there even after I remove it repeatedly, and that is annoying.

I completely agree with you!

Wow, this is some serious information right there and I would give it a try and see whether it work. Thanks mate!

@Aircon

Something that may be a brief way to find the problem . . .

In the Mac’s Terminal.app window, enter the following commands:

  • cd /private/var/db/com.apple.xpc.launchd/
  • ls -ale@

You should see a file having one of the following names:

  • loginitems.501.plist
  • loginitems.502.plist
  • loginitems.503.plist
  • loginitems.504.plist

The file permissions for each of those:

  • -rw-r--r-- 1 root wheel

Enter the command:

  • open . (open, followed by a period)

Open whatever ‘loginitems’ -named file that you find. You may use the TextEdit.app or use another text editor, such as BBEdit (< recommended).

What the contents of the file should look like, with NO ENTRIES:

If you find a ‘com.brave. . . .’ entry in the ‘loginitems’ -named file, that entry may be the problem. That entry may be sticking because of a file permissions problem, an Access Control List(s) (‘ACL’) problem, or some other reason: The tougher System Integrity Protection (‘SIP’) in the later Mac OS versions.

I wonder, now, that there may be a collision of sorts, between later Mac OS System Integrity Protection (‘SIP’) and Brave Browser installation, that causes Brave Browser to crash or otherwise develop difficulties.

Because, the file and folder permissions for the BraveSoftware folder:

  • `/Users/username/Library/Application Support/BraveSoftware/

are messed up - as in, ‘root’ has more control over the folder and its sub-contents, than you, the user.

Maybe System Integrity Protection (‘SIP’) is preventing the editing of the ‘loginitems’ -named file.

Maybe a little more accurate: SIP prevents the Brave Browser ‘install.sh’ script from completing the setting of necessary permissions?

@Evan123 and @steeven would either of you happen to have any ideas on this? Guess been multiple users with the same issue but no resolution. Not sure who might know the most on the Mac version of the browser and if there are any solutions or if this would need a Github

1 Like

Also tagged moderators in this topic created by @Slimothy.

Brave GitHub issue report link if anyone wants to create an issue report:

1 Like

Apparently, closing “Private Ads” might work because I have tried to switch it off and it appears that it does not auto-turned on the Brave Browser automatically till today, and hope that it would remain the same! :slight_smile:

1 Like