Brave Keeps Adding Itself To Login Items [Mac]

This issue has 3 threads (now 4) I can find and no fix yet for over 2 years. This is my last ditch effort to fix before I can’t take it any more.
2021 someone posted about it: Brave Adds Itself to Login Items
2020 someone posted about it: How do i stop brave from launching during start up
2019 someone posted about it: Brave browser opens on start-up

Description of the issue:
Brave continues to add itself to the Login Items on macOS.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Launch Brave. It adds itself to Login Items.
If you delete it from Login Items, close Brave, wait 5 seconds, and re-open Brave, it is re-added.

Actual Result (gifs and screenshots are welcome!):
See above.

Expected result:
Do NOT re-add to login items.

Reproduces how often:
See above.

Operating System and Brave Version(See the About Brave page in the main menu):
1.40.113 - Brave (but this has been going on for years on the other versions)
macOS Ventura Developer Beta 3 (but this has been going on for years on the other versions)
2021 MacBook Pro 16" M1 Max chip

Additional Information:
Used 3rd party apps to remove login items. No luck.
Deleted everything from /Library/LaunchDaemons and all of those places. No luck.

I literally cannot stop Brave from opening on startup and it’s infuriating.
How can I turn it off? And if I can’t, PLEASE let me know when a fix will be issued for this. I’ll swap back to FF until it’s fixed.


Probably a mistake to delete ‘everything from /Library/LaunchDaemons and all of those places’.

Better to be careful and specific.

If you have Brave Browser set to be the default Internet browser . . . choose some other Internet browser (Safari will do, for now).

Some Extensions may cause a problem, and you may need to:

  • Disable all Extensions
  • Remove all Extensions
  • Test Enable each Extension, alone, one-at-a-time in order to detect the influence of that Extension
  • Determine which Extensions are running in the background

Mission Control might have become an issue:

Borrowing from what @hnktong wrote in 2020 . . .

the places I know that house startup items are:

  • In System Preferences, Users & Groups, Login Items for your account
  • In your home folder/Library/LaunchAgents
  • In /System/Library/StartupItems
  • In /Library/StartupItems

And borrowing again from what @hnktong wrote in 2020 . . .

Something that at least used to trigger opening Brave (and Chrome) is if Hangouts is turned on (click to enlarge):

In a Brave Browser > New Window, go to: brave://settings/getStarted

  • Select: Open a specific page or set of pages
  • Select: Add a new page
  • Enter: about:blank (notice the colon)

In other words, you are DISABLING: Continue where you left off

Next, go to: brave://settings/clearBrowserData

For tab Advanced

  • Set: Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: `Cached images and files``

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

Next, go to: brave://settings/clearBrowserData

For tab On exit

  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files
  • Enable: Hosted app data

Click on the ‘Save’ button.

Reduce influence by websites:

In a Brave Browser - New Window, go to: brave://settings/content

Scroll down to Additional permissions . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to Content . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

RESTART YOUR COMPUTER and proceed to Safe Mode:

Starting up your Mac in safe mode can help you identify whether issues you’re experiencing are caused by software that loads as your Mac starts up.

  • Remove Brave Browser from list of Users > Login Items
  • Set Safari to be default Internet browser

RESTART YOUR COMPUTER and proceed to Safe Mode

  • Run Brave Browser
  • Exit / Quit Brave Browser

Does Brave Browser then show again in list of Users> Login Items?

While NOT running Brave Browser, locate the ‘Caches’ folder: /Users/username/Library/Caches/


  • locate the ‘com.brave.Browser’ folder and move the ‘com.brave.Browser’ folder to the Trash
  • locate the ‘BraveSoftware’ folder and move the ‘BraveSoftware’ folder to the Trash

Restart your Mac

Brave Sync might be a problem. You may have to Enable / Disable Brave Sync when needed, instead of leaving Brave Sync enabled.

For now, Disable Brave Sync, for testing your issue.

Worth a look:


The Screen Time settings will be shared across all your Apple devices if you’ve signed in using the same Apple ID, and ‘Share Across Devices’ is enabled on any device signed in to iCloud.

Quick Fix

Exit / Quit Brave Browser.

Use System Preferences > Users & Groups > Login Items . . . and REMOVE any Brave Browser items that would open automatically when you log in.

Quit System Preferences -AND- wait 1 minute.

Locate the ‘’ file:

  • /Users/username/Library/Preferences/

Select that ‘’ file and choose the ‘Get Info’ selection under the ‘File’ menu of the Mac OS ‘Finder’ menu bar.

Find in the Get Info window, the ‘Locked’ checkbox and Enable that checkbox. Close the Get Info window.

Exit / Quit applications and Log In. Did Brave Browser launch after the Log In? (Yes after Log In / No after Log In)

Exit / Quit applications and Restart your Mac. Did Brave Browser launch after the Restart? (Yes after Restart / No after Restart)

Login Items

Advanced Mac OS tools

You can really mess up here, when not careful and precise.


You can really mess up here, when not careful and precise.

defaults write

Hey there, thanks for the reply!

I have checked all of those folders, Brave was not in any of them. When I mentioned I deleted everything, I meant everything from other programs on my Mac that I didn’t want starting up. I left the System files alone. I work in the industry so no worries, I know what I’m doing there.

Hangouts has always been off

Those next settings look like they’re going to clear out a lot of my websites/cookies (though I used Cookie Auto Delete so I have very few cookies/cache to begin with).
I wish I had an extra Mac or two laying around to test.

Here’s what I did:

I deleted Brave from Login Items
I set Safari as Default.

I then rebooted Mac

Brave does NOT auto start!

As soon as I launch it, it re-adds. So it’s an improvement but overall doesn’t fix the issue.

For some reason, Brave REALLY WANTS to be added as a login item. No matter what. And it’s appearing to be unstoppable.

Is it a bug? I don’t know. But it really should not be this difficult to stop a f*****g browser from popping up every time I restart my Mac. It’s literally acting like malware.

I’m hoping someone else with a Mac might be able to chime in and let me know if they’ve had any luck because I’m about out of ideas and patience for Brave. Are there any Devs on this forum I can ping?

1 Like

Agreed wholeheartedly. It’s a real pain. I’ve followed all the steps before as well. Please reply if you find a solution.

1 Like

I feel like I’ve tried everything at this point. I’ve installed a few scripts from other sources to try to stop it as well and can’t. I’m glad it’s not just me.

Brave is hard-coded to automatically add itself to the Login Items on Mac at every single launch. That’s just all there is to it, I am confident in saying that now, and it appears to be intentional.

It is the single most frustrating thing. I’ve just been putting up with it for months but I can’t anymore. I was hoping it was a bug and would go away but appears not .

These forum posts everyone just suggests the same things over and over but I feel like maybe they don’t have a Mac and they don’t actually understand what’s going on.

I also can’t believe more people aren’t pissed off and aggravated about this issue.

If I do get it resolved I will definitely post an update. I wish I knew a Brave dev I could @ or tag on here somehow. It’s probably a super easy fix too. Ugh.

Bumping this thread.

Know nothing about macOS. Posting a couple of links that may be of interest. No idea if these will provide additional information that will help troubleshoot or not.

Issue 140017: Chome keeps getting added to Login Items for automatic start on login

MacOS automatically start chrome browser at startup

Below is an article about windows, but may give you some ideas. Looks like you probably performed most of the troubleshooting steps using comparable tools on your macOS. Thought I would link anyway since there may be a couple of things that may be impacting that you haven’t addressed.

Google Chrome opening automatically when PC boots up

Thanks for the links! Yep I have read through those previously actually, interesting how it was reported in Chrome nearly a decade ago, and I think Chrome fixed it, but not Brave.

I don’t think it is fixed. The issue report is still open and recurring again in some instances. May be a regression. The entries for #140017 has posts from 2013 - 2022. A long time for this issue to be hanging around. lol

Issue reported in Feb 2022. Closed and merged into #140017 as duplicate.

Issue 1300443: Chrome keeps adding itself to “Login Items”

I thought the Hangouts and Trusteer Endpoint Protection/Rapport references were interesting in the other articles. Wondering if you have any extensions that are causing problems.

Edit: Really didn’t finish the extension thought. Do you have any extensions and did you try disabling as @289wk suggested. Might even try updating or just uninstalling extensions to see if that has any impact. Lot of work for a maybe though. :slightly_frowning_face:

Interesting. I don’t have Chrome installed and don’t plan to for privacy reasons so I can’t test, but I used to use it and never had that issue for the whole 10+ years I used it on various Macs previously.

Extensions, nothing crazy. I have all of that Hangouts crap turned off and anything Google related and Crypto related.

In fact I do not believe Extensions have access to change System Settings on a Mac. So it would have to be Brave itself doing that. :confused:

If you have the time or are just curious, you may want to save your Brave-Browser folder to an external device, uninstall Brave Release version, then clean install Beta and/or Nightly versions without adding any extensions and see if those versions have the same issue. Again, a lot of work for maybe nothing…

Brave Beta is actually running on Chromium 103.0.5060.114 whereas Nightly and Release are at 103.0.5060.134. Might provide additional insight on whether this is a Chromium issue vs a Brave issue.

Leaving it at that. I haven’t a clue about macOS issues and just throwing things out there. Whether or not these things actually apply is a different question. Time to back out. :joy:

I do hope your issue can be solved. To get Brave support and dev team eyes on the issue, you can tag the moderators here and/or go create a Brave GitHub issue report. I would do both.

Good luck and take care! :smiley:

1 Like

I appreciate the suggestion! I might have to try that. My few extensions do have some pretty custom configs so it might be best for me to procure another Mac to test.
I’ll check and find a list of the mods here as well to tag. Thank you again for the suggestions.

Tagging Brave staff for you. Hopefully they respond. :slightly_smiling_face:

@Mattches @steeven (veteran admin/mods) @evan123 (unknown role but has recently been posting frequently and may be able to help)

SaltyBanana is another mod but she is on PTO at the moment. The Brave Community Admins and Mods are displayed on the About page.

1 Like

Thank you Chocoholic! I appreciate it :slight_smile:

1 Like

Very strange issue here. Worth noting that I’m also using macOS and do not have this issue. I’ll have to ask the team about this. FWIW, I do not believe this is being done “intentionally”.

Hope to have more information for you soon.


Thank you! I was able to acquire another MacBook (Air, not Pro) and tested there and it did not exhibit the behavior. But so many folks here and on other forums mention the issue. It’s super strange… Hope to learn more thank you for checking.

1 Like

Out of curiosity, when you shutdown or reboot your machine, do you have the Reopen windows when logging back in option enabled? If so, this will reopen the browser (or anything else that was not closed/quit) regardless of whether or not it is added to the list of login apps:

1 Like

Yep I keep that checked. I close everything before shutting down. Same setting I’ve had checked for 10+ years of Mac use. Also, that’s checked on the Mac that doesn’t have the issue.

But regardless of that toggle, Brave is actively adding itself to Login Items which is separate from that menu you showed. On macOS Ventura (Dev Beta) I’m on, it actually tells me with a notification each time a program adds itself to the Login Items (probably to alert users of stuff like this where a program is adding itself over and over in this case). So I see every time I launch Brave after removing it from Login Items, it is re-adding itself to Login items. :frowning:

I have the same issue. MacBook Pro 14" running macOS 12.5 Monterey. Even if I shut down without checking the option to reopen the programs after starting and if I remove all the times from the login items, Brave returns to the list and opens at each start. My fiancée has the same MacBook model, bought on the same day and configured the same way, on hers it doesn’t happen. I have already made a complete clean of Brave and reinstalled it, but the problem persists. Very weird!

1 Like

Sounds like we are in the exact same boat.

I’m messing with Firefox instead now to see if it can fit my needs instead of Brave. I really don’t see any of the Devs fixing this anytime soon since it’s just so weird/random of an issue.

Very sad but it is what it is. I really liked Brave before this for many years! It was my go-to and the browser I used to recommend to folks.

But with it repeatedly adding itself to Login Items, it’s acting like malware. I can’t stand it. It opens up before my VPN EVERY TIME too which is a HUGE no-no.

If anyone finds a fix, please let me know and update this thread. But until then I think I’m going to have to give up on Brave. :frowning: