Brave Browser keeps opening at startup on Mac

Brave Browser keeps opening at startup on my Mac. Before I turn off my laptop I make sure I close and quit all apps because I know Mac will open them up when turned on. Lately Brave will open at start up and I don’t know why. I just thought it was a one time thing but it happens all the time now when I turn on my Mac. I have settings turned off for it to open at startup, within the Mac setting and Brave settings. I’ve looked and searched on how to stop this but there isn’t a permanent solution. I don’t know what else to do. I ended up creating this account minutes before typing this because it’s my last hope really.

1 Like

Not sure about this one. Ill tag @rodrige @Saoiray @Aman_M @Chocoholic Please help. Thanks!

That’s bad. I’m not a Mac user so can’t say why it’s still happening when auto-start is disabled. Maybe someone else can give an insight.

Meanwhile, @miniboba You should post the first 3 heads found here- brave://version/

1 Like

@miniboba Welcome to the community.

Posting another topic that I think is related. In the topic, an extension (Wappalyzer) was causing the problem. There are other troubleshooting options and additional information too. You might want to read through the topic and see if anything works for you. Please post an update and please include your Brave and macOS version information found at brave://version. Hope this helps!

1 Like

Nice find. I am also thinking this could be it @miniboba. Damn extensions!

1 Like

Is this what you mean for me to post? Sorry I don’t really understand what you mean.

Brave 1.43.93 Chromium: 105.0.5195.127 (Official Build) (arm64)
Revision 912488396852bf658ab32465980c0b93a3c27a83-refs/branch-heads/5195@{#1109}
OS macOS Version 12.6 (Build 21G115)

So recently added extensions to the browser but I took them off when I read your post. I waited a few days to reply to see if it worked. It didn’t. I’m still having issues with it opening at startup.
I did look at one of the forums that said to turn off hangouts in the settings. I’ll see if that worked and update you all if it did work.

1 Like

That’s what I meant. Do post an update if you find a solution.

@miniboba I really thought an extension was probably causing the problem. Of course it wouldn’t be that easy! Going to recap what has been done so far and list the other things suggested to try in the linked topic above (Brave Keeps Adding Itself To Login Items [Mac]). Please post an update. After confirming you tested everything, the next step would be to tag Brave support for help.

Just to confirm, you have tried the following but problem persists:

  1. Removed all extensions
  2. Disabled Hangouts at brave://settings/extensions

Please confirm you tried the following (or do the following) and post an update:

  1. Cleared history/cache for All time on the Advanced tab at brave://settings/clearBrowserData

  2. Disabled Continue running background apps when Brave is closed at brave://settings/system

  3. Right click Brave icon in the dock/applications list and confirm Open at login is not checked. Uncheck and restart if it is.

  4. Brave Keeps Adding Itself To Login Items [Mac] - #17 by Mattches

    when you shutdown or reboot your machine, do you have the Reopen windows when logging back in option enabled? If so, this will reopen the browser (or anything else that was not closed/quit) regardless of whether or not it is added to the list of login apps:
    image

  5. Check that Brave is not in the following startup locations

    • In System Preferences, Users & Groups, Login Items for your account
    • In your home folder/Library/LaunchAgents
    • In /System/Library/StartupItems
    • In /Library/StartupItems

    Remove and/or temporarily disable startup items (How to Add, Remove, and Delay Startup Apps on a Mac). Temporarily disabling startup items may be an indicator that another startup item in the list is causing Brave to open at startup.

  6. If you use Sync, leave the Sync chain. Results? Add mac back to Sync chain. Results?

  7. Run anti-virus/malware removal program.

  8. Install Brave Beta and see if doing the same in Beta.

2 Likes
  • I tried the “turn off hangouts”. I’m still having the issue.
  • I cleared data. Still having the issue.
  • I already checked login items and checked the startup locations. I check every time I get on my Mac. There are no login items. Still having the issue.
  • I did the Sync chain part, still having the issue.

I’ll have to do the anti-virus/malware removal program soon. As well as Brave beta. I’ll update you soon if it works.


This actually isn’t in my settings.

2 Likes

Good job trying all that. Appreciate it. Will now tag @Mattches for an insight.

1 Like

To confirm, you’ve tried disabling all/any extensions you’ve installed in the browser at this time (not just “hangouts”) and still get the same results?

Hi @Mattches,

It should not be necessary to remove extensions to have Brave not re-add itself continuously to the startup items on the Mac.

If extensions are what’s causing this behavior (I suspect they are not, and that this is a Brave bug, but I could be wrong), Brave should either disable this function or have an option titled:

“Allow extensions to force Brave to continuously re-add itself to your login/startup items even when you remove it and uncheck every other option in the Brave settings relating to this.”

Until Brave either fixes this bug or provides a mechanism to stop this behavior, I’m uninstalling Brave and switching back to Chrome.

1 Like

I’m here to update. I don’t know what worked exactly. I did not run malware program, nor did I get Brave beta because it stopped opening up at startup which is great. I just don’t want to jinx it happening again.
I just want to know why exactly this was happening in the first place. I’ve never had this issue since I first started using Brave in February.

@miniboba,
Just to confirm, the behavior just kind of…stopped — you didn’t make any changes that may have caused it to stop?

My last post last week I had mentioned how all the changes I made didn’t work and still experienced the issue. I didn’t make any changes after that and left it as is to see if the issue would still continue. It continued for two more days after that post but then it just stopped on its own. Haven’t seen it open at startup since.