Glitched Rewards on Android and Linux devices

Brave Rewards on my desktop & phone are both showing that my wallet is Unverified (eventhough it is), clicking the Brave Icon next to Shield buffers continuously or doesn’t open at all, the window for the captcha doesn’t pop up, and brave://rewards on phone is blank.
Also, in brave://rewards-internals, both devices show that Rewards profile not yet created, Total balance 0 BAT, and Rewards state: Not connected.

Operating System: Linux Mint 20.3
Version 1.44.108 Chromium: 106.0.5249.103 (Official Build) (64-bit)

Is your browser wallet currently verified? Yes

What date did you verify your wallet? September 8, 2021

Have you been able to successfully receive payments in the past? Yes

Are you using a VPN? No

Are you in a supported region (see here for list of supported regions)? Yes

Does your device pass the SafteyNet check (Android only)? Yes

Have you manually turned off Auto-contribute on all of your devices linked to Gemini? Yes

Videos showing issues below (just press play):

check if anything from the above helps

No, it didn’t work. Thanks for the suggestion.

I guess you’ll have to raise a ticket. Raise one here

Tried that as well. Input of a wallet ID is mandatory in order to submit a ticket. It no longer shows any information on my PC or phone, only the following:

Rewards info

Rewards profile not yet created

Balance info

Total balance 0 BAT

Custodial account connection info

Rewards state: Not connected

Umm okay. @Mattches @SaltyBanana @chriscat anything you guys can do?

1 Like

Umm could you just enter 123 or something and submit the ticket?

Hi @Alchemist

Sorry to hear you were experiencing issues with Brave Rewards.
Do you know how much BAT you had in your Estimated Earnings?

Hello, @SaltyBanana . On the desktop, I think it was 15.25 BAT. I’m not sure how much was on my phone, probably 2 BAT.

Are there any updates on how I can solve this issue? Nearing month two, unfortunately.

Hi @Alchemist

Could you kindly send me a direct message with the following:

  1. A link to your original post
  2. Screenshot of your brave://rewards page
  3. Screenshot of your brave://rewards-internals page


@Alchemist and @SaltyBanana did this ever get figured out? Asking as seeing similar issue being reported over at Brave Rewards verification has stopped working

Hey @Saoiray ,

No, not really. One of the problems I’m experiencing apparently is a known issue waiting to be addressed. For now, I just have to wait since Brave Rewards is unusable right now.

Going to Settings > Brave Rewards > Reset Brave Rewards helped solve one of the issues on my phone but it will reset your monthly earnings, so it’s best to do it after payments get processed. The same can’t be done in Settings for the Desktop though - at least not yet.

Latest update: Solved

For anyone having a similar issue - while the issue persists on my phone, this is how I managed to fix the problems on my desktop.

Sandwich menu > Create a new profile > Setup a new Brave Rewards Wallet > Verify your new wallet (The device limit has been lifted when linking to your custodial wallet, so that shouldn’t be an issue.)

That’s all. It’s been two years of issues with Brave Rewards solved that easily.

Disclaimer: This will essentially start you off from scratch, so that means you’ll have to transfer everything (passwords, extensions, bookmarks, re-login to all regularly browsed websites). It was annoying but it took maybe 15 minutes. Be sure to do this AFTER you’ve received any payment for the month.

Hopefully this is found useful to others experiencing something similar. I’ll experiment a bit to see if there’s another way to do it without starting over and update this with any results.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.