File extensions won't associate with Brave

windows

#1

Description of the issue:
I can’t associate brave with any file extension.
Steps to Reproduce:
Open Windows File Explorer.
Right click on any file.
Select Open with > Choose another app
Check Always use this app to open .extension files
Click Look for another app on this PC
Navigate to brave.exe and select it to open that file.
Actual Result
The file opens in a new Brave tab, but the file won’t open in Brave again without using the Open with menu option.


Expected result:
The icon of files with the selected extension change to the Brave logo, and the files with the new logo open in Brave by default
Reproduces how often:
Every time.
Brave Version
Version 0.56.15 Chromium: 70.0.3538.110 (Official Build) (64-bit)
Reproducible on current live release (yes/no):
Yes
Additional Information:
Selecting the option Brave in the image simply reopens the current window asking which app I want to use. I believe it is attempting to open the Muon version which I deleted. Selecting Brave Browser opens the file in the browser without assigning Brave to always open that type of file when the Always use this app box is checked.


#2

@deoxal,
What type of file are you trying to associate with Brave?
I can associate any compatible file type using the method you provided in your steps.


#3

I am trying to associate .pdf, .html, .lnk, and .url with brave. I believe the problem has to do with the fact that Brave and Brave Browser appear separately in the app menu, and that there is some other lingering data that refuses to be updated. After downloading and installing v0.56.15, I deleted v0.25.2 which is what Brave is pointing to.

In the default apps section in Windows Settings Brave is the default browser, but it is in the center of the image with a blue background whereas Brave Browser is not centered in apps menu. It could be nothing, but the inconsistency makes me think that different shortcuts/file paths are being used.


#4

@deoxal, would you mind sharing an image of what you’re describing?


#5

Here is a screenshot of my default apps in the Windows settings.


I’ve tried clicking the Reset button, and then reassigning Brave as the default browser.

I also tried setting file associations through the Choose default apps by file type option, but neither of those things worked. Here is an image of the second thing I tried:


Selecting Brave for .pdf changes the image from the Chrome logo to the Brave logo in the settings page as it is shown in the image above. However, the icon for .pdf files shown in Windows File Explorer is now a default icon. icon
Attempting to open a .pdf file from Windows File Explorer brings up the menu in my original post. Only this time the old Brave version I deleted is listed directly under Keep using this app. Selecting it reopens the same menu like before. Selecting Brave Browser in the image above, sets Microsoft Edge as the default app to open .pdf files.

Selecting Brave Browser for .html does exactly the same thing as selecting Brave for .pdf, it doesn’t even change the app next to .html to Brave Browser just Brave. Selecting Brave does the same thing as well.

By which I mean doing this:
.


becomes this:

Finally, .url only has an option called Internet Browser and the option to Look for an app in the Store, and .lnk, only has that last option.

I did my best to be as clear as possible, but I’m not sure if all of that made sense. So feel free to ask me to clarify anything.


#6

@deoxal,
Excellent reporting. I’m going to have to dig into this given that all of the above worked for me, except for .pdf. Let me ask around and see if anyone else may know what’s going on.
Appreciate your patience.